aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/ruby.scm18
1 files changed, 9 insertions, 9 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index d1643e8a68..c7bb133848 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -1212,22 +1212,22 @@ next patch version for example.")
(define-public ruby-rjb
(package
(name "ruby-rjb")
- (version "1.5.5")
+ (version "1.6.7")
(source (origin
(method url-fetch)
(uri (rubygems-uri "rjb" version))
(sha256
(base32
- "1ppj8rbicj3w0nhh7f73mflq19yd7pzdzkh2a91hcvphriy5b0ca"))))
+ "0ck802bm8cklhmqsgzhsa0y8lg80qy52dp3m8rlld3zc5gv1rsb9"))))
(build-system ruby-build-system)
(arguments
- `(#:tests? #f ; no rakefile
- #:phases
- (modify-phases %standard-phases
- (add-before 'build 'set-java-home
- (lambda* (#:key inputs #:allow-other-keys)
- (setenv "JAVA_HOME" (assoc-ref inputs "jdk"))
- #t)))))
+ (list
+ #:tests? #f ; no rakefile
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-before 'build 'set-java-home
+ (lambda* (#:key inputs #:allow-other-keys)
+ (setenv "JAVA_HOME" (assoc-ref inputs "jdk")))))))
(native-inputs
`(("jdk" ,icedtea "jdk")))
(synopsis "Ruby-to-Java bridge using the Java Native Interface")
>doc: Update bit about SSH in the VM....Ludovic Courtès 2019-04-26vm-image: Remove NetworkManager & co. and add the DHCP client....Ludovic Courtès 2019-04-26vm-image: Use the actual file name of the current file....Ludovic Courtès 2019-04-26system: Provide a new VM image configuration....Ludovic Courtès 2019-04-10doc: Adjust desktop instructions for GDM....Ludovic Courtès 2019-04-05services: xorg: Add 'set-xorg-configuration'....Ludovic Courtès 2019-04-03gnu: Add example system configuration for asus-c201....Timothy Sample 2019-03-28system: Fix typo in desktop example....Ludovic Courtès 2019-03-27services: Deprecate 'xfce-desktop-service'....Ludovic Courtès 2019-03-27services: Deprecate 'gnome-desktop-service'....Ludovic Courtès 2019-03-25accounts: Add default value for the 'home-directory' field of <user-account>....Ludovic Courtès 2019-03-13Remove traces of "GuixSD"....Ludovic Courtès 2019-01-23gnu: Replace all cons* with beginner-friendly (append (list ...))....Pierre Neidhardt 2019-01-23gnu: Fix missing EFI entry in "desktop" example....Pierre Neidhardt 2019-01-20services: Use guix-service-type....Efraim Flashner 2018-12-24doc: Example vm-image doesn't need firmware....Efraim Flashner 2018-12-03doc: Fix "desktop" OS config example....Laura Lazzati 2018-11-26services: openssh: Install OpenSSH in the system profile....Ludovic Courtès 2018-10-18services: dhcp-client: Deprecate 'dhcp-client-service' procedure....Ludovic Courtès 2018-07-05doc: Improve UEFI/BIOS bootloader documentation....Ludovic Courtès