aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorArtyom V. Poptsov <poptsov.artyom@gmail.com>2024-07-07 10:13:03 +0300
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-07-07 14:37:40 +0100
commitff1bb647b5d66af5fb1fbacdea08b46a6db90e77 (patch)
treeaacd057b1e545f840a7631e4eebe051d14a980de /gnu
parentc6fae8a300cca29a45d6acf9bf804ef9a71bb6cd (diff)
downloadguix-ff1bb647b5d66af5fb1fbacdea08b46a6db90e77.tar.gz
guix-ff1bb647b5d66af5fb1fbacdea08b46a6db90e77.zip
gnu: Add go-github-com-ipfs-go-ipld-cbor.
* gnu/packages/ipfs.scm (go-github-com-ipfs-go-ipld-cbor): New variable. Change-Id: I1a85366eb558fe3043fe39d8aabd4bf14f98a32a Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/ipfs.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/ipfs.scm b/gnu/packages/ipfs.scm
index 2248c6f3cd..f548e4a25e 100644
--- a/gnu/packages/ipfs.scm
+++ b/gnu/packages/ipfs.scm
@@ -270,6 +270,38 @@ throughout its lifetime.")
"Common utilities used by @code{go-ipfs} and other related Go packages.")
(license license:expat)))
+(define-public go-github-com-ipfs-go-ipld-cbor
+ (package
+ (name "go-github-com-ipfs-go-ipld-cbor")
+ (version "0.1.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ipfs/go-ipld-cbor")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0yxk4sbf1fk9aaizzpz3h30049wqvaz0s3jnbdd5akhj7wg89h21"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:go go-1.21
+ #:import-path "github.com/ipfs/go-ipld-cbor"))
+ (propagated-inputs
+ (list go-github-com-ipfs-go-block-format
+ go-github-com-ipfs-go-cid
+ go-github-com-ipfs-go-ipfs-util
+ go-github-com-ipfs-go-ipld-format
+ go-github-com-multiformats-go-multihash
+ go-github-com-polydawn-refmt
+ go-github-com-whyrusleeping-cbor-gen))
+ (home-page "https://github.com/ipfs/go-ipld-cbor")
+ (synopsis "A cbor implementation of the @code{go-ipld-format}")
+ (description
+ "An implementation of a @url{https://cbor.io/, CBOR} encoded merkledag object.")
+ (license license:expat)))
+
(define-public go-github-com-ipfs-go-ipld-format
(package
(name "go-github-com-ipfs-go-ipld-format")