aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorAndrew Tropin <andrew@trop.in>2023-02-14 16:20:37 +0400
committerAndrew Tropin <andrew@trop.in>2023-02-14 17:08:35 +0400
commitf9485e59f07342eb420303cd459133813563b2ed (patch)
treeae310d55eee40f2935a4a2cf4bcd853ae5e97aeb /gnu
parent8fb1af3483e0e8b3794d4db08f061036bd29c2ac (diff)
downloadguix-f9485e59f07342eb420303cd459133813563b2ed.tar.gz
guix-f9485e59f07342eb420303cd459133813563b2ed.zip
gnu: Add tree-sitter-rust.
gnu/packages/tree-sitter.scm (tree-sitter-rust): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tree-sitter.scm6
1 files changed, 6 insertions, 0 deletions
diff --git a/gnu/packages/tree-sitter.scm b/gnu/packages/tree-sitter.scm
index fafd65942d..9dcf273f83 100644
--- a/gnu/packages/tree-sitter.scm
+++ b/gnu/packages/tree-sitter.scm
@@ -405,3 +405,9 @@ will be used in description and synopsis."
"1pqr24bj68lgi1w2cblr8asfby681l3032jrppq4n9x5zm23fi6n"
(git-version "0.19.0" revision commit)
#:commit commit)))
+
+(define-public tree-sitter-rust
+ (tree-sitter-grammar
+ "rust" "Rust"
+ "149jhy01mqvavwa8jlxb8bnn7sxpfq2x1w35si6zn60b7kqjlx8f"
+ "0.20.3"))
dcdb93f9278'>tests: Skip lint tests when HTTP server cannot listen....Ludovic Courtès 2020-06-14lint: Add 'check-for-collisions' checker....Ludovic Courtès 2020-01-17lint: vulnerabilities: Avoid 'mock' in test....Ludovic Courtès 2019-10-20tests: Avoid now-deprecated 'make-struct'....Ludovic Courtès 2019-09-02lint: Add 'archival' checker....Ludovic Courtès 2019-09-02tests: 'with-http-server' accepts multiple responses....Ludovic Courtès 2019-08-17tests: Relax expectations for the 'home-page' checker....Ludovic Courtès 2019-07-20lint: Add test for 'source'....Ludovic Courtès 2019-07-20lint: Update tests to (guix lint) migration....Ludovic Courtès 2019-07-15lint: Move the linting code to a different module....Christopher Baines 2019-07-15scripts: lint: Handle warnings with a record type....Christopher Baines