aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@scratchpost.org>2020-05-03 16:12:30 +0200
committerDanny Milosavljevic <dannym@scratchpost.org>2020-05-03 20:35:50 +0200
commitf8a0065ae391bc9f717033e612f342741c66d946 (patch)
tree0481ac0999269e40976bef29df8dda1892ffd2d8 /gnu
parentaf7a8e718dddd12c3dddf92bfce2f79471fa4a0d (diff)
downloadguix-f8a0065ae391bc9f717033e612f342741c66d946.tar.gz
guix-f8a0065ae391bc9f717033e612f342741c66d946.zip
install: Add f2fs-tools to the installation image.
* gnu/system/install.scm (installation-os)[packages]: Add f2fs-tools.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/system/install.scm1
1 files changed, 1 insertions, 0 deletions
diff --git a/gnu/system/install.scm b/gnu/system/install.scm
index 8804585215..6435c1bff4 100644
--- a/gnu/system/install.scm
+++ b/gnu/system/install.scm
@@ -524,6 +524,7 @@ Access documentation at any time by pressing Alt-F2.\x1b[0m
mdadm
dosfstools ;mkfs.fat, for the UEFI boot partition
btrfs-progs
+ f2fs-tools
jfsutils
openssh ;we already have sshd, having ssh/scp can help
wireless-tools iw wpa-supplicant-minimal iproute
emu.
@@ -1296,11 +1289,12 @@ virtualization library.")
(lambda* (#:key tests? #:allow-other-keys)
(when tests?
(setenv "HOME" "/tmp")
+ (setenv "XDG_CACHE_HOME" "/tmp")
(system "Xvfb :1 &")
(setenv "DISPLAY" ":1")
;; Dogtail requires that Assistive Technology support be enabled
(setenv "GTK_MODULES" "gail:atk-bridge")
- (invoke "dbus-run-session" "--" "python" "setup.py" "test_ui"))
+ (invoke "dbus-run-session" "--" "pytest" "--uitests"))
#t))
(add-after 'install 'glib-or-gtk-compile-schemas
(assoc-ref glib-or-gtk:%standard-phases 'glib-or-gtk-compile-schemas))
@@ -1330,7 +1324,9 @@ virtualization library.")
("gtk+" ,gtk+ "bin") ; gtk-update-icon-cache
("perl" ,perl) ; pod2man
("intltool" ,intltool)
+ ("rst2man" ,python-docutils)
;; The following are required for running the tests
+ ;; ("python-pytest" ,python-pytest)
;; ("python-dogtail" ,python-dogtail)
;; ("xvfb" ,xorg-server-for-tests)
;; ("dbus" ,dbus)