aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2024-07-21 16:35:27 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2024-07-21 16:39:40 +0200
commitf2841228321c81991d59dadcacff38e8aa0aff27 (patch)
treefebd205fbbbcdd4b49cd4e559cb92ff38adea570 /gnu
parentb4f3bb565bb7db201071fc5fd32609a24c5a0a0f (diff)
downloadguix-f2841228321c81991d59dadcacff38e8aa0aff27.tar.gz
guix-f2841228321c81991d59dadcacff38e8aa0aff27.zip
gnu: emacs-dape: Update to 0.14.0.
* gnu/packages/emacs-xyz.scm (emacs-dape): Update to 0.14.0. Change-Id: I262ae61eaaf5a29ae114a058b51da5e1f1f07e8d
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs-xyz.scm90
1 files changed, 44 insertions, 46 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 89b22e2f23..a87a909a5e 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -31513,56 +31513,54 @@ in Docker environment.")
(license license:gpl3+))))
(define-public emacs-dape
- (let ((commit "51fad7df7473778fbc4bac703317de7f7713b307")
- (revision "0"))
- (package
- (name "emacs-dape")
- (version (git-version "0.12.0" revision commit))
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/svaante/dape")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32 "1jics02b9fxjs0lykiv7z924z18id550mqhf6piqzv0sgan91pg2"))))
- (build-system emacs-build-system)
- (arguments
- ;; FIXME python tests pass, JS tests require additional dependencies
- ;; See https://lists.sr.ht/~abcdw/rde-devel/patches/51878
- (list #:tests? #f
- #:test-command #~'("emacs" "--batch" "-l" "dape.el"
- "-l" "dape-tests.el"
- "-f" "ert-run-tests-batch-and-exit")
- #:phases
- #~(modify-phases %standard-phases
- (add-after 'unpack 'support-unwrapped-python
- (lambda _
- (substitute* "dape.el"
- (("command \"python\"")
- "command \"python3\""))))
- (add-before 'check 'pre-check
- (lambda* (#:key tests? inputs #:allow-other-keys)
- (if tests?
- (setenv
- "PATH"
- (string-append
- (getenv "PATH")
- ":" (dirname (search-input-file inputs "/bin/python3"))
- ":" (dirname (search-input-file inputs "/bin/node"))))
- (format #t "test suite not run~%")))))))
- (native-inputs (list node-lts python-minimal python-debugpy))
- (propagated-inputs (list emacs-jsonrpc))
- (home-page "https://github.com/svaante/dape")
- (synopsis "Debug Adapter Protocol for Emacs")
- (description
- "Dape is a debug adapter client for Emacs. The debug adapter protocol,
+ (package
+ (name "emacs-dape")
+ (version "0.14.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/svaante/dape")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0227i5z9vkr2l9isrlssdwda844jvpcs4i9ryj0cwj6i60jbf1g3"))))
+ (build-system emacs-build-system)
+ (arguments
+ ;; FIXME python tests pass, JS tests require additional dependencies
+ ;; See https://lists.sr.ht/~abcdw/rde-devel/patches/51878
+ (list #:tests? #f
+ #:test-command #~'("emacs" "--batch" "-l" "dape.el"
+ "-l" "dape-tests.el"
+ "-f" "ert-run-tests-batch-and-exit")
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'support-unwrapped-python
+ (lambda _
+ (substitute* "dape.el"
+ (("command \"python\"")
+ "command \"python3\""))))
+ (add-before 'check 'pre-check
+ (lambda* (#:key tests? inputs #:allow-other-keys)
+ (if tests?
+ (setenv
+ "PATH"
+ (string-append
+ (getenv "PATH")
+ ":" (dirname (search-input-file inputs "/bin/python3"))
+ ":" (dirname (search-input-file inputs "/bin/node"))))
+ (format #t "test suite not run~%")))))))
+ (native-inputs (list node-lts python-minimal python-debugpy))
+ (propagated-inputs (list emacs-jsonrpc))
+ (home-page "https://github.com/svaante/dape")
+ (synopsis "Debug Adapter Protocol for Emacs")
+ (description
+ "Dape is a debug adapter client for Emacs. The debug adapter protocol,
much like its more well-known counterpart, the language server protocol,
aims to establish a common API for programming tools. However, instead of
functionalities such as code completions, it provides a standardized
interface for debuggers.")
- (license license:gpl3+))))
+ (license license:gpl3+)))
(define-public emacs-dap-mode
(package