aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-08-03 15:53:54 +0200
committerRicardo Wurmus <rekado@elephly.net>2017-08-04 11:23:52 +0200
commited69963b03d71928f8c926ed62e5d6f5e78d9b2a (patch)
tree3d3b9a8899e2cf8ce69d7ec4fb8d39193e23052c /gnu
parent88c8f247e594239807aafe80d5e8b084d07e32f6 (diff)
downloadguix-ed69963b03d71928f8c926ed62e5d6f5e78d9b2a.tar.gz
guix-ed69963b03d71928f8c926ed62e5d6f5e78d9b2a.zip
gnu: Add js-html5shiv.
* gnu/packages/javascript.scm (js-html5shiv): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/javascript.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/javascript.scm b/gnu/packages/javascript.scm
index 43bc0bbf6d..8364651918 100644
--- a/gnu/packages/javascript.scm
+++ b/gnu/packages/javascript.scm
@@ -134,3 +134,28 @@ be able to view it naturally and easily.")))
script to enable responsive web designs in browsers that don't support CSS3
Media Queries.")
(license license:expat)))
+
+(define-public js-html5shiv
+ (package
+ (name "js-html5shiv")
+ (version "3.7.3")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/aFarkas/html5shiv/"
+ "archive/" version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0inlbpxpqzdyi24lqagzf7l24zxg0y02xcpqs2h4npjscazzw7hg"))))
+ (build-system minify-build-system)
+ (home-page "https://github.com/aFarkas/html5shiv")
+ (synopsis "Enable HTML5 sectioning elements in legacy browsers")
+ (description "The HTML5 Shiv enables use of HTML5 sectioning elements in
+legacy Internet Explorer and provides basic HTML5 styling for Internet
+Explorer 6-9, Safari 4.x (and iPhone 3.x), and Firefox 3.x.")
+ ;; From the file "MIT and GPL2 licenses.md":
+ ;;
+ ;; This software is licensed under a dual license system (MIT or GPL
+ ;; version 2). This means you are free to choose with which of both
+ ;; licenses (MIT or GPL version 2) you want to use this library.
+ (license (list license:expat license:gpl2))))
led, for HTTPS support in the 'guix download' command. Note that 'guix import pypi' requires this functionality. Unless `--disable-daemon' was passed, the following packages are needed: - [[https://sqlite.org/][SQLite 3]] - [[http://www.bzip.org][libbz2]] - [[https://gcc.gnu.org][GCC's g++]] When `--disable-daemon' was passed, you instead need the following: - [[https://nixos.org/nix/][Nix]] * Installation See the manual for the installation instructions, either by running info -f doc/guix.info "Installation" or by checking the [[https://www.gnu.org/software/guix/manual/guix.html#Installation][web copy of the manual]]. For information on installation from a Git checkout, please see the section "Building from Git" in the manual. * Installing Guix from Guix You can re-build and re-install Guix using a system that already runs Guix. To do so: - Start a shell with the development environment for Guix: guix environment guix - Re-run the 'configure' script passing it the option '--localstatedir=/somewhere', where '/somewhere' is the 'localstatedir' value of the currently installed Guix (failing to do that would lead the new Guix to consider the store to be empty!). - Run "make", "make check", and "make install". * How It Works Guix does the high-level preparation of a /derivation/. A derivation is the promise of a build; it is stored as a text file under =/gnu/store/xxx.drv=. The (guix derivations) module provides the `derivation' primitive, as well as higher-level wrappers such as `build-expression->derivation'. Guix does remote procedure calls (RPCs) to the Guix or Nix daemon (the =guix-daemon= or =nix-daemon= command), which in turn performs builds and accesses to the Nix store on its behalf. The RPCs are implemented in the (guix store) module. * Installing Guix as non-root The Guix daemon allows software builds to be performed under alternate user accounts, which are normally created specifically for this purpose. For instance, you may have a pool of accounts in the =guixbuild= group, and then you can instruct =guix-daemon= to use them like this: $ guix-daemon --build-users-group=guixbuild However, unless it is run as root, =guix-daemon= cannot switch users. In that case, it falls back to using a setuid-root helper program call =nix-setuid-helper=. That program is not setuid-root by default when you install it; instead you should run a command along these lines (assuming Guix is installed under /usr/local): # chown root.root /usr/local/libexec/nix-setuid-helper # chmod 4755 /usr/local/libexec/nix-setuid-helper * Contact GNU Guix is hosted at https://savannah.gnu.org/projects/guix/. Please email <bug-guix@gnu.org> for bug reports or questions regarding Guix and its distribution; email <gnu-system-discuss@gnu.org> for general issues regarding the GNU system. Join #guix on irc.freenode.net. * Guix & Nix GNU Guix is based on [[https://nixos.org/nix/][the Nix package manager]]. It implements the same package deployment paradigm, and in fact it reuses some of its code. Yet, different engineering decisions were made for Guix, as described below. Nix is really two things: a package build tool, implemented by a library and daemon, and a special-purpose programming language. GNU Guix relies on the former, but uses Scheme as a replacement for the latter. Using Scheme instead of a specific language allows us to get all the features and tooling that come with Guile (compiler, debugger, REPL, Unicode, libraries, etc.) And it means that we have a general-purpose language, on top of which we can have embedded domain-specific languages (EDSLs), such as the one used to define packages. This broadens what can be done in package recipes themselves, and what can be done around them. Technically, Guix makes remote procedure calls to the ‘nix-worker’ daemon to perform operations on the store. At the lowest level, Nix “derivations” represent promises of a build, stored in ‘.drv’ files in the store. Guix produces such derivations, which are then interpreted by the daemon to perform the build. Thus, Guix derivations can use derivations produced by Nix (and vice versa). With Nix and the [[https://nixos.org/nixpkgs][Nixpkgs]] distribution, package composition happens at the Nix language level, but builders are usually written in Bash. Conversely, Guix encourages the use of Scheme for both package composition and builders. Likewise, the core functionality of Nix is written in C++ and Perl; Guix relies on some of the original C++ code, but exposes all the API as Scheme. * Related software - [[https://nixos.org][Nix, Nixpkgs, and NixOS]], functional package manager and associated software distribution, are the inspiration of Guix - [[https://www.gnu.org/software/stow/][GNU Stow]] builds around the idea of one directory per prefix, and a symlink tree to create user environments - [[https://www.pvv.ntnu.no/~arnej/store/storedoc_6.html][STORE]] shares the same idea - [[https://live.gnome.org/OSTree/][GNOME's OSTree]] allows bootable system images to be built from a specified set of packages - The [[https://www.gnu.org/s/gsrc/][GNU Source Release Collection]] (GSRC) is a user-land software distribution; unlike Guix, it relies on core tools available on the host system