aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorKatherine Cox-Buday <cox.katherine.e@gmail.com>2020-06-04 17:40:56 -0500
committerOleg Pykhalov <go.wigust@gmail.com>2020-06-09 22:07:53 +0300
commitea94e4d38eec38ead58492907a2b14321e986bd1 (patch)
tree08b085e6ab6eb02d87dfb70d724ab939eaee5a5a /gnu
parent81b045e149daffd113208601b764fdb47cf6c14b (diff)
downloadguix-ea94e4d38eec38ead58492907a2b14321e986bd1.tar.gz
guix-ea94e4d38eec38ead58492907a2b14321e986bd1.zip
gnu: Add sbcl-stumpwm-net.
* gnu/packages/wm.scm (sbcl-stumpwm-net): New variable. Signed-off-by: Oleg Pykhalov <go.wigust@gmail.com>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/wm.scm18
1 files changed, 18 insertions, 0 deletions
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index daeddc3c0f..6165c805da 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -1783,6 +1783,24 @@ windows in the current X session.")
between windows.")
(license (list license:gpl2+ license:gpl3+ license:bsd-2))))
+(define-public sbcl-stumpwm-net
+ (package
+ (inherit stumpwm-contrib)
+ (name "sbcl-stumpwm-net")
+ (arguments
+ '(#:asd-system-name "net"
+ #:tests? #f
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'chdir (lambda _ (chdir "modeline/net") #t)))))
+ (home-page
+ "https://github.com/stumpwm/stumpwm-contrib/tree/master/modeline/net")
+ (synopsis "Modeline support for network connectivity")
+ (description "Modeline support for network connectivity.")
+ (supported-systems
+ (filter (lambda (a) (string-contains a "linux")) %supported-systems))
+ (license license:gpl3+)))
+
(define-public lemonbar
(let ((commit "35183ab81d2128dbb7b6d8e119cc57846bcefdb4")
(revision "1"))
gnu/packages/openbox.scm, gnu/packages/pdf.scm, gnu/packages/perl-check.scm, gnu/packages/perl.scm, gnu/packages/python-compression.scm, gnu/packages/python-crypto.scm, gnu/packages/python-web.scm, gnu/packages/python-xyz.scm, gnu/packages/python.scm, gnu/packages/qt.scm, gnu/packages/ruby.scm, gnu/packages/rust.scm, gnu/packages/scheme.scm, gnu/packages/serialization.scm, gnu/packages/shells.scm, gnu/packages/ssh.scm, gnu/packages/suckless.scm, gnu/packages/tbb.scm, gnu/packages/telephony.scm, gnu/packages/text-editors.scm, gnu/packages/textutils.scm, gnu/packages/time.scm, gnu/packages/tls.scm, gnu/packages/tor.scm, gnu/packages/version-control.scm, gnu/packages/video.scm, gnu/packages/vim.scm, gnu/packages/web.scm, gnu/packages/wm.scm, gnu/packages/xdisorg.scm, gnu/packages/xfce.scm, gnu/packages/xml.scm, gnu/packages/xorg.scm, gnu/services/certbot.scm, gnu/services/desktop.scm, gnu/services/version-control.scm, gnu/services/web.scm, guix/import/hackage.scm, guix/licenses.scm: Likewise. Signed-off-by: Efraim Flashner <efraim@flashner.co.il> nikita 2020-05-08gnu: spacefm: Fix functionality....* gnu/packages/lxde.scm (spacefm): Update package definition. [source]: Change from url-fetch to git-fetch. [inputs]: Add btrfs-progs, coreutils, e2fsprogs, fsarchiver, gphotofs, ntfs-3g and procps. [arguments]<#:phases>[patch-source-files]: Delete phase. [patch-bin-dirs]: New phase. [patch-mime-dirs]: New phase. [patch-setuid-progs]: New phase. [patch-spacefm-conf]: New phase. [arguments]<:configure-flags>: Add "--with-preferable-sudo". Signed-off-by: Danny Milosavljevic <dannym@scratchpost.org> Raghav Gururajan 2020-05-01gnu: spacefm: Fix privilege and disk management....* gnu/packages/lxde.scm (spacefm)[inputs]: Remove dbus. Add ktsuss. [arguments]<#:phases>[patch-source-files]: New phase. Signed-off-by: Danny Milosavljevic <dannym@scratchpost.org> Raghav Gururajan 2020-04-24gnu: spacefm: Add dependencies for extra functionality....* gnu/packages/lxde.scm (spacefm): Add dependencies for extra functionality. Adding these inputs and making required changes to build-system+arguments; provides icons, privilege-management and disk-management. Raghav Gururajan 2020-04-05gnu: spacefm: Make some inputs native....* gnu/packages/lxde.scm (spacefm)[inputs]: Move desktop-files-utils from here... [native-inputs]: ...to here. Signed-off-by: Danny Milosavljevic <dannym@scratchpost.org> Vincent Legoll 2020-02-12gnu: spacefm: Use HTTPS home page....* gnu/packages/lxde.scm (spacefm)[home-page]: Use HTTPS. Tobias Geerinckx-Rice 2019-12-25gnu: lxtask: Don't use NAME in source URI....* gnu/packages/lxde.scm (lxtask)[source]: Hard-code NAME. Tobias Geerinckx-Rice 2019-12-25gnu: lxtask: Update to 0.1.9....* gnu/packages/lxde.scm (lxtask): Update to 0.1.9. Tobias Geerinckx-Rice