aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-13 09:16:58 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:17:32 +0200
commite59e60e7d107d95654580e91e64c852e1dcdca0e (patch)
tree48eef4c6683bbbc4f80fb6a991043193dc6d1f9b /gnu
parent8b2b7bd23975c1ea7be99ea247e58478e95f9370 (diff)
downloadguix-e59e60e7d107d95654580e91e64c852e1dcdca0e.tar.gz
guix-e59e60e7d107d95654580e91e64c852e1dcdca0e.zip
gnu: Add texlive-pgfkeyx.
* gnu/packages/tex.scm (texlive-pgfkeyx): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index c93cafa478..7e768088ac 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -3160,6 +3160,27 @@ allows the user to draw spectra using their own data.")
"This package provides LaTeX macros to draw UML diagrams using PGF.")
(license license:gpl3+)))
+(define-public texlive-pgfkeyx
+ (package
+ (name "texlive-pgfkeyx")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/pgfkeyx/" "tex/latex/pgfkeyx/")
+ (base32
+ "0g5wvhlyfplv0fd0nsxpw3al9wmk0hw0pjvyyplh1vzdk5rr3xzq")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/pgfkeyx")
+ (synopsis "Extended and more robust version of @code{pgfkeys}")
+ (description
+ "The package extends and improves the robustness of the @code{pgfkeys}
+package. In particular, it can deal with active comma, equality sign, and
+slash in key parsing. The difficulty with active characters has long been
+a problem with the @code{pgfkeys} package. The package also introduces
+handlers beyond those that @code{pgfkeys} can offer.")
+ (license license:lppl1.3+)))
+
(define-public texlive-amiri
(package
(name "texlive-amiri")