aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-04-08 23:37:02 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2019-04-10 20:54:18 +0200
commite163d78eeafeac943c776ec7a7a1bbb9953dd682 (patch)
treebf0557b63e033a919ef969900953a28ed07f57fb /gnu
parent32ce5382ef043e560ff9e531b9e129271c0c255f (diff)
downloadguix-e163d78eeafeac943c776ec7a7a1bbb9953dd682.tar.gz
guix-e163d78eeafeac943c776ec7a7a1bbb9953dd682.zip
gnu: emacs-loop: Don't use unstable tarball.
* gnu/packages/emacs-xyz.scm (emacs-loop)[source]: Use GIT-FETCH and GIT-FILE-NAME.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs-xyz.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index e0d4ff59bd..ac3eb42333 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -9736,13 +9736,13 @@ tramp.")
(version "1.3")
(source
(origin
- (method url-fetch)
- (uri (string-append "https://github.com/Wilfred/loop.el/archive/"
- version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/Wilfred/loop.el.git")
+ (commit version)))
+ (file-name (git-file-name name version))
(sha256
- (base32
- "1z3rhh3zyjabz36410yz0lp4a0qwwj0387as662wvx3z9y54jia9"))))
+ (base32 "1gs95xnmnn8aa4794k7h8mw1sz1nfdh9v0caqj6yvnsdnwy74n5x"))))
(build-system emacs-build-system)
(home-page "https://github.com/Wilfred/loop.el")
(synopsis "Imperative loop structures for Emacs")