aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-16 17:15:46 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:18:36 +0200
commitd642554212195a3d0a5db4d99ce8674e29770457 (patch)
treea765baedc148fc6b0acb9293b2461c9741fa4a01 /gnu
parent31db747769a36127eb47c3ba4ebaef3315f1856f (diff)
downloadguix-d642554212195a3d0a5db4d99ce8674e29770457.tar.gz
guix-d642554212195a3d0a5db4d99ce8674e29770457.zip
gnu: Add texlive-latexindent.
* gnu/packages/tex.scm (texlive-latexindent): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 758248786f..71ecb72138 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -2663,6 +2663,27 @@ only.")
style file.")
(license license:lppl)))
+(define-public texlive-latexindent
+ (package
+ (name "texlive-latexindent")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/support/latexindent/"
+ "scripts/latexindent/")
+ (base32
+ "1k2d09z2my38nhxhzdq53jg4alzg5jzirdsb1qa7szm3dya46xgm")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (arguments (list #:link-scripts #~(list "latexindent.pl")))
+ (inputs (list perl))
+ (home-page "https://ctan.org/pkg/latexindent")
+ (synopsis "Indent a LaTeX document, highlighting the programming structure")
+ (description
+ "The Perl script processes a LaTeX file, indenting parts so as to
+highlight the structure for the reader.")
+ (license license:gpl3)))
+
(define-public texlive-tex-ini-files
(package
(name "texlive-tex-ini-files")