aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-10-09 11:20:28 -0400
committerLudovic Courtès <ludo@gnu.org>2024-08-31 10:42:16 +0200
commitd2f10fa2b58b610013e108dd51969ae066cdc165 (patch)
treea95540e552e83da42c8301fb2c8c1a4c88da5597 /gnu
parenta800c6867274d91142626bfd5f6276a7a816bfa5 (diff)
downloadguix-d2f10fa2b58b610013e108dd51969ae066cdc165.tar.gz
guix-d2f10fa2b58b610013e108dd51969ae066cdc165.zip
gnu: dirvish: Import the correct set of modules.
* gnu/packages/backup.scm (dirvish) [arguments] <modules>: Replace %default-gnu-imported-modules with %default-gnu-modules. Delete trailing #t. Change-Id: I041a65441055a21f141bb7ea4a563e2624cd783c
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/backup.scm5
1 files changed, 2 insertions, 3 deletions
diff --git a/gnu/packages/backup.scm b/gnu/packages/backup.scm
index 78112e8a2a..cd27f04922 100644
--- a/gnu/packages/backup.scm
+++ b/gnu/packages/backup.scm
@@ -843,7 +843,7 @@ NTFS volumes using @code{ntfs-3g}, preserving NTFS-specific attributes.")
"1kbxa1irszp2zw8hd5qzqnrrzb4vxfivs1vn64yxnj0lak1jjzvb"))))
(arguments
`(#:modules ((ice-9 match) (ice-9 rdelim)
- ,@%default-gnu-imported-modules)
+ ,@%default-gnu-modules)
#:phases
;; This mostly mirrors the steps taken in the install.sh that ships
;; with dirvish, but simplified because we aren't prompting interactively
@@ -919,8 +919,7 @@ NTFS volumes using @code{ntfs-3g}, preserving NTFS-specific attributes.")
;; Write out executables
(for-each write-pl executables)
;; Write out man pages
- (for-each write-man man-pages)
- #t))))))
+ (for-each write-man man-pages)))))))
(inputs
(list perl rsync perl-libtime-period perl-libtime-parsedate))
(home-page "http://dirvish.org/")