aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-13 10:43:08 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:18:00 +0200
commitcdfd9745dd3cc6c715a3087ef2ec58e6d5a5cf14 (patch)
treecb4b2b51bc3eb752b8bc74a8ac6f1ac7c7876b19 /gnu
parent06d305cef29d7d39d13239bb6dfc8163f34176dc (diff)
downloadguix-cdfd9745dd3cc6c715a3087ef2ec58e6d5a5cf14.tar.gz
guix-cdfd9745dd3cc6c715a3087ef2ec58e6d5a5cf14.zip
gnu: Add texlive-tikzcodeblocks.
* gnu/packages/tex.scm (texlive-tikzcodeblocks): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 7bcc6cc609..04795d75a5 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -4934,6 +4934,25 @@ Beveridge's article Too good to be Truchet in issue 08 of Chalkdust.")
The user can modify color, shape, and viewpoint.")
(license license:lppl1.3c)))
+(define-public texlive-tikzcodeblocks
+ (package
+ (name "texlive-tikzcodeblocks")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/tikzcodeblocks/"
+ "tex/latex/tikzcodeblocks/")
+ (base32
+ "04c8bjl3l97vsh7cydbh20wnq93my19avkhcf4kh0g5cvq02nizp")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/tikzcodeblocks")
+ (synopsis "Helps to draw codeblocks like Scratch, NEPO and PXT in TikZ")
+ (description
+ "@code{tikzcodeblocks} is a LaTeX package for typesetting blockwise
+graphic programming languages like Scratch, NEPO or PXT.")
+ (license license:lppl1.3c)))
+
(define-public texlive-amiri
(package
(name "texlive-amiri")