aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-03-18 11:45:32 +0200
committerEfraim Flashner <efraim@flashner.co.il>2024-07-19 00:43:02 +0300
commitbd3dc07af0bd4bded79b92934ef0068f9bec61bb (patch)
tree507cb79200880f1526a35508654798f2c2ebdfeb /gnu
parente59d4a9d5d09d0f86cc65361f45f2d3544bdf876 (diff)
downloadguix-bd3dc07af0bd4bded79b92934ef0068f9bec61bb.tar.gz
guix-bd3dc07af0bd4bded79b92934ef0068f9bec61bb.zip
gnu: Add rust-tungstenite-0.21.
* gnu/packages/crates-web.scm (rust-tungstenite-0.21): New variable. (rust-tungstenite-0.20): Inherit from rust-tungstenite-0.21. Change-Id: I03a43803ecb77a529989a666aa9c8ab98d5f04d1
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/crates-web.scm53
1 files changed, 44 insertions, 9 deletions
diff --git a/gnu/packages/crates-web.scm b/gnu/packages/crates-web.scm
index ca13af85c7..fd7bf3a386 100644
--- a/gnu/packages/crates-web.scm
+++ b/gnu/packages/crates-web.scm
@@ -6165,39 +6165,40 @@ the Trust-DNS client to use rustls for TLS.")
(("rust-openssl" ,rust-openssl-0.10)
("rust-tokio" ,rust-tokio-0.1))))))
-(define-public rust-tungstenite-0.20
+(define-public rust-tungstenite-0.21
(package
(name "rust-tungstenite")
- (version "0.20.1")
+ (version "0.21.0")
(source
(origin
(method url-fetch)
(uri (crate-uri "tungstenite" version))
(file-name (string-append name "-" version ".tar.gz"))
(sha256
- (base32 "1fbgcv3h4h1bhhf5sqbwqsp7jnc44bi4m41sgmhzdsk2zl8aqgcy"))))
+ (base32 "1qaphb5kgwgid19p64grhv2b9kxy7f1059yy92l9kwrlx90sdwcy"))))
(build-system cargo-build-system)
(arguments
`(#:cargo-inputs (("rust-byteorder" ,rust-byteorder-1)
("rust-bytes" ,rust-bytes-1)
("rust-data-encoding" ,rust-data-encoding-2)
- ("rust-http" ,rust-http-0.2)
+ ("rust-http" ,rust-http-1)
("rust-httparse" ,rust-httparse-1)
("rust-log" ,rust-log-0.4)
("rust-native-tls" ,rust-native-tls-0.2)
("rust-rand" ,rust-rand-0.8)
- ("rust-rustls" ,rust-rustls-0.21)
- ("rust-rustls-native-certs" ,rust-rustls-native-certs-0.6)
+ ("rust-rustls" ,rust-rustls-0.22)
+ ("rust-rustls-native-certs" ,rust-rustls-native-certs-0.7)
+ ("rust-rustls-pki-types" ,rust-rustls-pki-types-1)
("rust-sha1" ,rust-sha1-0.10)
("rust-thiserror" ,rust-thiserror-1)
("rust-url" ,rust-url-2)
("rust-utf-8" ,rust-utf-8-0.7)
- ("rust-webpki-roots" ,rust-webpki-roots-0.24))
+ ("rust-webpki-roots" ,rust-webpki-roots-0.26))
#:cargo-development-inputs (("rust-criterion" ,rust-criterion-0.5)
("rust-env-logger" ,rust-env-logger-0.10)
("rust-input-buffer" ,rust-input-buffer-0.5)
- ("rust-net2" ,rust-net2-0.2)
- ("rust-rand" ,rust-rand-0.8))))
+ ("rust-rand" ,rust-rand-0.8)
+ ("rust-socket2" ,rust-socket2-0.5))))
(home-page "https://github.com/snapview/tungstenite-rs")
(synopsis "Lightweight stream-based WebSocket implementation")
(description
@@ -6208,6 +6209,40 @@ design abstracts away all the internals of the WebSocket protocol but still
makes them accessible for those who wants full control over the network.")
(license (list license:expat license:asl2.0))))
+(define-public rust-tungstenite-0.20
+ (package
+ (inherit rust-tungstenite-0.21)
+ (name "rust-tungstenite")
+ (version "0.20.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "tungstenite" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "1fbgcv3h4h1bhhf5sqbwqsp7jnc44bi4m41sgmhzdsk2zl8aqgcy"))))
+ (arguments
+ `(#:cargo-inputs (("rust-byteorder" ,rust-byteorder-1)
+ ("rust-bytes" ,rust-bytes-1)
+ ("rust-data-encoding" ,rust-data-encoding-2)
+ ("rust-http" ,rust-http-0.2)
+ ("rust-httparse" ,rust-httparse-1)
+ ("rust-log" ,rust-log-0.4)
+ ("rust-native-tls" ,rust-native-tls-0.2)
+ ("rust-rand" ,rust-rand-0.8)
+ ("rust-rustls" ,rust-rustls-0.21)
+ ("rust-rustls-native-certs" ,rust-rustls-native-certs-0.6)
+ ("rust-sha1" ,rust-sha1-0.10)
+ ("rust-thiserror" ,rust-thiserror-1)
+ ("rust-url" ,rust-url-2)
+ ("rust-utf-8" ,rust-utf-8-0.7)
+ ("rust-webpki-roots" ,rust-webpki-roots-0.24))
+ #:cargo-development-inputs (("rust-criterion" ,rust-criterion-0.5)
+ ("rust-env-logger" ,rust-env-logger-0.10)
+ ("rust-input-buffer" ,rust-input-buffer-0.5)
+ ("rust-net2" ,rust-net2-0.2)
+ ("rust-rand" ,rust-rand-0.8))))))
+
(define-public rust-tungstenite-0.19
(package
(inherit rust-tungstenite-0.20)