aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-08-11 19:53:12 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-08-11 19:53:12 +0100
commitb13e353147eaf4513fe74babc5bcd21cef4c669f (patch)
treea968621e45e9c344e40b794e9235c9345c9c26f4 /gnu
parentd1315bb2bab344f37ebfaa4572654ff78ea8e845 (diff)
downloadguix-b13e353147eaf4513fe74babc5bcd21cef4c669f.tar.gz
guix-b13e353147eaf4513fe74babc5bcd21cef4c669f.zip
gnu: Add go-github-com-charlievieth-fastwalk.
* gnu/packages/golang-xyz.scm (go-github-com-charlievieth-fastwalk): New variable. Change-Id: I1e684ede86688f0bb5a1d9bd1cbb4015366d5f8b
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/golang-xyz.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 8f45dd86be..43b99f2c1b 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -1326,6 +1326,31 @@ marshalling and unmarshalling library in Go. It uses code generation and not
reflection.")
(license license:expat)))
+(define-public go-github-com-charlievieth-fastwalk
+ (package
+ (name "go-github-com-charlievieth-fastwalk")
+ (version "1.0.8")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/charlievieth/fastwalk")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "17zy17q31p8b93bf703rr0xqafp02bb0slkrgpxb8r0aaxz3zg4y"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/charlievieth/fastwalk"))
+ (home-page "https://github.com/charlievieth/fastwalk")
+ (synopsis "Fast directory traversal for Golang")
+ (description
+ "Package fastwalk provides a faster version of
+@url{/path/filepath#@code{WalkDir,filepath.WalkDir}} for file system scanning
+tools.")
+ (license license:expat)))
+
(define-public go-github-com-cheggaaa-pb
(package
(name "go-github-com-cheggaaa-pb")