aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-04-08 23:36:27 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2019-04-10 20:54:17 +0200
commitafca2f41c2034c4c09ed30606cc82fc274338cc3 (patch)
tree8a6909eac395fed7c6903689c20ff3d5ea89ee17 /gnu
parent5521a3e74656fbd0dbd3fa25e3abd9815f6cd835 (diff)
downloadguix-afca2f41c2034c4c09ed30606cc82fc274338cc3.tar.gz
guix-afca2f41c2034c4c09ed30606cc82fc274338cc3.zip
gnu: emacs-move-text: Don't use unstable tarball.
* gnu/packages/emacs-xyz.scm (emacs-move-text)[source]: Use GIT-FETCH and GIT-FILE-NAME.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs-xyz.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index e9f5766909..f869ab814b 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -9456,13 +9456,13 @@ and @code{erc-send-modify-hook} to download and show images.")
(version "2.0.8")
(source
(origin
- (method url-fetch)
- (uri (string-append "https://github.com/emacsfodder/move-text/archive/"
- version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/emacsfodder/move-text.git")
+ (commit version)))
+ (file-name (git-file-name name version))
(sha256
- (base32
- "1sjfja9r25692pgcldgnjzkapzy970m14jh9l4pajysiqcdk72g0"))))
+ (base32 "06jxk5g23822gfmwrxhc34zand3dr8p2wjh1zs3j61ibz6n0nmz1"))))
(build-system emacs-build-system)
(home-page "https://github.com/emacsfodder/move-text")
(synopsis "Move current line or region with M-up or M-down")