aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-04-08 23:35:35 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2019-04-10 20:54:17 +0200
commita670c3a55315a3b62ccd7ffbff46cea3230eb05f (patch)
tree038558bcfba0521e41690dcaa2cb2374cbd3c86a /gnu
parent6e215be72f28b87960cef99e29d4c7a396fb2e38 (diff)
downloadguix-a670c3a55315a3b62ccd7ffbff46cea3230eb05f.tar.gz
guix-a670c3a55315a3b62ccd7ffbff46cea3230eb05f.zip
gnu: emacs-makey: Don't use unstable tarball.
* gnu/packages/emacs-xyz.scm (emacs-makey)[source]: Use GIT-FETCH and GIT-FILE-NAME.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs-xyz.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 755207f812..fb3a7f1df3 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -9190,13 +9190,13 @@ newsreader.")
(version "0.3")
(source
(origin
- (method url-fetch)
- (uri (string-append "https://github.com/mickeynp/makey/archive/"
- version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/mickeynp/makey.git")
+ (commit version)))
+ (file-name (git-file-name name version))
(sha256
- (base32
- "0kzl4q1wf2zhkx9nrymxa67n99iq0bj7zqhpaz4byksna1hsxfmv"))))
+ (base32 "1rr7vpm3xxzcaam3m8xni3ajy8ycyljix07n2jzczayri9sd8csy"))))
(build-system emacs-build-system)
(home-page "https://github.com/mickeynp/makey")
(synopsis "Emacs interactive command-line mode")