aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-16 09:57:04 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:18:30 +0200
commit6481cd3bda3cdfffe1946580e3a8b326d70c2199 (patch)
tree981bb5c381197939ade2d070e736a756496393c4 /gnu
parentb193df530c4736fb1972e79754b022f676427c4d (diff)
downloadguix-6481cd3bda3cdfffe1946580e3a8b326d70c2199.tar.gz
guix-6481cd3bda3cdfffe1946580e3a8b326d70c2199.zip
gnu: Add texlive-ctanupload.
* gnu/packages/tex.scm (texlive-ctanupload): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index e7d2c0a422..3e77197453 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -1528,6 +1528,29 @@ used by those intending to install the package, or by those who need to
incorporate it in a distribution.")
(license license:lppl1.3c)))
+(define-public texlive-ctanupload
+ (package
+ (name "texlive-ctanupload")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/support/ctanupload/"
+ "scripts/ctanupload/")
+ (base32
+ "0w4k9sslhnpn5l90wbr7cr7pv8fhiiabasbi6l6gw3w3nrfmarh4")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (arguments (list #:link-scripts #~(list "ctanupload.pl")))
+ (inputs (list perl))
+ (home-page "https://ctan.org/pkg/ctanupload")
+ (synopsis "Support for users uploading to CTAN")
+ (description
+ "The package provides a Perl script that allows the uploads of
+a contribution to CTAN from the command line. The aim is to simplify the
+release process for LaTeX package authors. Note by the CTAN
+team (2015-02-05): It seems that this script is currently not working.")
+ (license license:gpl3)))
+
(define-public texlive-dvipsconfig
(package
(name "texlive-dvipsconfig")