aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorJohn Kehayias <john.kehayias@protonmail.com>2022-07-05 13:12:43 -0400
committerLudovic Courtès <ludo@gnu.org>2022-07-18 00:21:31 +0200
commit543f27caef548d1b0ee1e3c9859bcfa4f0976e78 (patch)
treeb09d583c97cd3f41f7a64447730129847c9acb60 /gnu
parent969e86784bdba4737baf07d12c5c3117b7c56b48 (diff)
downloadguix-543f27caef548d1b0ee1e3c9859bcfa4f0976e78.tar.gz
guix-543f27caef548d1b0ee1e3c9859bcfa4f0976e78.zip
gnu: Add python-msal.
* gnu/packages/python-web.scm (python-msal): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-web.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 6bb73fa6d2..525c3cc0b0 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -2955,6 +2955,38 @@ with python-requests.")
adapter for use with the Requests library.")
(license license:asl2.0)))
+(define-public python-msal
+ (package
+ (name "python-msal")
+ (version "1.18.0")
+ (home-page
+ "https://github.com/AzureAD/microsoft-authentication-library-for-python")
+ (source (origin
+ (method git-fetch)
+ ;; Pypi does not have tests.
+ (uri (git-reference (url home-page) (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "02d9vlvp08q1yffgn7a0y19451py1jly67q5ld6m2d9xidbrvac1"))))
+ (build-system python-build-system)
+ (arguments
+ ;; Tests (all?) rely on network access and only some can be disabled by
+ ;; setting the environment variable TRAVIS_TAG.
+ (list #:tests? #f))
+ (native-inputs (list python-mock))
+ (propagated-inputs (list python-cryptography python-pyjwt python-requests))
+ (synopsis "Microsoft Authentication Library (MSAL) for Python")
+ (description
+ "The Microsoft Authentication Library for Python enables applications to
+integrate with the Microsoft identity platform. It allows you to sign in
+users or apps with Microsoft identities (Azure AD, Microsoft Accounts and
+Azure AD B2C accounts) and obtain tokens to call Microsoft APIs such as
+Microsoft Graph or your own APIs registered with the Microsoft identity
+platform. It is built using industry standard OAuth2 and OpenID Connect
+protocols.")
+ (license license:expat)))
+
(define-public python-oauthlib
(package
(name "python-oauthlib")
d=7f7d52cc9a72dc079eaa1cc2d3e68bd80dae12ec'>gnu: Add lxmenu-data....ng0 2017-01-23gnu: menu-cache: Update to 1.0.2....ng0 2017-01-23gnu: pcmanfm, libfm: Update to 1.2.5....ng0 2017-01-23gnu: lxterminal: Update to 0.3.0....ng0 2016-07-22gnu: Update URLs for sourceforge.net....Leo Famulari 2016-07-05gnu: menu-cache: Update to 1.0.1....Efraim Flashner 2016-07-05gnu: lxtask: Update to 0.1.7....Efraim Flashner 2016-07-05gnu: lxrandr: Update to 0.3.1....Efraim Flashner 2016-07-05gnu: lxappearance: Update to 0.6.2....Efraim Flashner 2016-04-13gnu: pcmanfm, libfm: Update to 1.2.4....Raymond Nicholson 2015-07-22gnu: Add lxrandr....Mathieu Lirzin 2015-07-22gnu: Add lxtask....Mathieu Lirzin 2015-07-22gnu: Add lxterminal....Mathieu Lirzin 2015-07-22gnu: Add pcmanfm....Mathieu Lirzin 2015-07-22gnu: Add libfm....Mathieu Lirzin 2015-07-22gnu: Add menu-cache....Mathieu Lirzin 2015-07-22gnu: Add libfm-extra....Mathieu Lirzin 2015-07-19gnu: lxappearance: Add missing slash....Mathieu Lirzin 2015-07-16gnu: Add lxappearance....Mathieu Lirzin