aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMichael Rohleder <mike@rohleder.de>2020-11-02 06:30:27 +0100
committerGuillaume Le Vaillant <glv@posteo.net>2020-11-02 09:59:09 +0100
commit48b00a4c7efadbb654bf28e9e4e61bb23f70a964 (patch)
tree1b8d8bbfbaeea8593384f267784464017151d88e /gnu
parente1f5c2292b88525414b5d0336a00bfa6741d4f14 (diff)
downloadguix-48b00a4c7efadbb654bf28e9e4e61bb23f70a964.tar.gz
guix-48b00a4c7efadbb654bf28e9e4e61bb23f70a964.zip
gnu: stumpish: Fix xprop call.
* gnu/packages/wm.scm (stumpish): Fix xprop call. [inputs]: Add xprop. [arguments]: Add substitution of xprop. Signed-off-by: Guillaume Le Vaillant <glv@posteo.net>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/wm.scm6
1 files changed, 5 insertions, 1 deletions
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 58252e7095..b76542692c 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -36,6 +36,7 @@
;;; Copyright © 2020 Boris A. Dekshteyn <harlequin78@gmail.com>
;;; Copyright © 2020 Marcin Karpezo <sirmacik@wioo.waw.pl>
;;; Copyright © 2020 EuAndreh <eu@euandre.org>
+;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1722,7 +1723,8 @@ productive, customizable lisp based systems.")
(name "stumpish")
(inputs
`(("bash" ,bash)
- ("rlwrap" ,rlwrap)))
+ ("rlwrap" ,rlwrap)
+ ("xprop" ,xprop)))
(build-system trivial-build-system)
(arguments
'(#:modules ((guix build utils))
@@ -1734,6 +1736,8 @@ productive, customizable lisp based systems.")
(substitute* "stumpish"
(("rlwrap") (string-append (assoc-ref %build-inputs "rlwrap")
"/bin/rlwrap"))
+ (("xprop") (string-append (assoc-ref %build-inputs "xprop")
+ "/bin/xprop"))
(("/bin/sh") (string-append (assoc-ref %build-inputs "bash")
"/bin/bash")))
(install-file "stumpish" (string-append %output "/bin")))))
class='msg-avail'>...Fixes <https://issues.guix.gnu.org/53157>. Reported by Efraim Flashner <efraim@flashner.co.il>. * configure.ac: Require Guile >= 3.0.3. * doc/guix.texi (Requirements): Update accordingly. Ludovic Courtès 2021-11-23maint: "make dist" builds tarballs in 'ustar' format....This allows us to have file names longer than 99 characters. * configure.ac: Pass 'tar-ustar' to 'AM_INIT_AUTOMAKE'. Ludovic Courtès 2021-06-01maint: Require Guile 3.0....* configure.ac: Require Guile 3.0. * doc/guix.texi (Requirements): Adjust accordingly. * gnu/packages/package-management.scm (guile2.2-guix): Remove. * guix/lint.scm (exception-with-kind-and-args?): Remove 'cond-expand'. * guix/scripts/deploy.scm (deploy-machine*): Likewise. * guix/store.scm (call-with-store): Likewise. * guix/swh.scm (http-get*, http-post*): Likewise. * guix/ui.scm (without-compiler-optimizations, guard*) (call-with-error-handling): Likewise. Ludovic Courtès 2021-05-03nls: Do not update po files on first make invocation....We need to update the minimal gettext version to take advantage of new features. Before this patch, the first make invocation would modify po/guix and po/packages po files, and we advised to run `git checkout po` to clean the changes. * configure.ac (AM_GNU_GETTEXT_VERSION): Update to 0.19.1. * po/guix/Makevars: Set PO_DEPENDS_ON_POT to no. * po/packages/Makevars: Set PO_DEPENDS_ON_POT to no. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> Julien Lepiller 2021-04-25import: Remove Nix importer....This importer has suffered from bitrot and no longer works with current Nix and Nixpkgs. See <https://bugs.gnu.org/32339> and <https://bugs.gnu.org/36255>. * guix/import/snix.scm, guix/scripts/import/nix.scm, tests/snix.scm: Remove. * Makefile.am (MODULES, SCM_TESTS): Remove them. * guix/scripts/import.scm (importers): Remove "nix". * build-aux/test-env.in: Remove NIXPKGS variable. * configure.ac: Remove '--with-nixpkgs' option. * doc/guix.texi (Invoking guix import): Remove bit about "guix import nix". * etc/completion/fish/guix.fish: Likewise. Ludovic Courtès 2021-04-23build: Add a check for Guile-Lib....* configure.ac: Check if the Guile-Lib module is present and recent enough and warn in case it isn't. Maxim Cournoyer 2021-03-17maint: Check whether Guile-zlib is recent enough....This is a followup to a04aef2430645357d7796969d4b6453478ff8a3f. * m4/guix.m4 (GUIX_CHECK_GUILE_ZLIB): New macro. * configure.ac: Use it when checking for Guile-zlib. Ludovic Courtès 2021-02-04build: Add '--with-channel-commit' and related configure flags....Partially fixes <https://bugs.gnu.org/45896>. * m4/guix.m4 (GUIX_CHANNEL_METADATA): New macro. * configure.ac: Use it. * guix/config.scm.in (%channel-metadata): Adjust accordingly. Ludovic Courtès