aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-04-08 23:33:02 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2019-04-10 20:54:13 +0200
commit3b5d4f72ca30bb7d7ec4c6820ae82037b2f96283 (patch)
tree3eaeaf3097ae4c738c525bfa976f111c2d8a6c38 /gnu
parent57a07f9cb6a1fedd3e96557ced05a8fa40ae0479 (diff)
downloadguix-3b5d4f72ca30bb7d7ec4c6820ae82037b2f96283.tar.gz
guix-3b5d4f72ca30bb7d7ec4c6820ae82037b2f96283.zip
gnu: emacs-evil-quickscope: Don't use unstable tarball.
* gnu/packages/emacs-xyz.scm (emacs-evil-quickscope)[source]: Use GIT-FETCH and GIT-FILE-NAME.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs-xyz.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 8353e41218..669dd8b62b 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -8360,13 +8360,13 @@ emulates Vim features and provides Vim-like key bindings.")
(version "0.1.4")
(source
(origin
- (method url-fetch)
- (uri (string-append "https://github.com/blorbx/evil-quickscope/archive/v"
- version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/blorbx/evil-quickscope.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
(sha256
- (base32
- "1r26a412mmar7vbf89zcifswiwpdg30mjzj32xdyqss57aqi83ma"))))
+ (base32 "1ja9ggj70wf0nmma4xnc1zdzg2crq9h1cv3cj7cgwjmllflgkfq7"))))
(build-system emacs-build-system)
(propagated-inputs
`(("emacs-evil" ,emacs-evil)))