aboutsummaryrefslogtreecommitdiff
path: root/gnu/system/pam.scm
diff options
context:
space:
mode:
authorTanguy Le Carrour <tanguy@bioneland.org>2021-11-25 12:33:15 +0100
committerLeo Famulari <leo@famulari.name>2021-11-25 14:10:42 -0500
commitaab9e79fa4a09459e35561d69cc140b6142dcb49 (patch)
tree70dccc283ad6b8e465d360c681580dd96b3646ae /gnu/system/pam.scm
parentea7233befb9570cce47e5ca71725b285a580cd22 (diff)
downloadguix-aab9e79fa4a09459e35561d69cc140b6142dcb49.tar.gz
-rw-r--r--
gnu/packages/ruby.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 908dfd5751..e0a76fed2c 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -193,6 +193,25 @@ a focus on simplicity and productivity.")
(("/bin/sh") (which "sh")))
#t)))))))
+(define-public ruby-concurrent
+ (package
+ (name "ruby-concurrent")
+ (version "1.0.5")
+ (source (origin
+ (method url-fetch)
+ (uri (rubygems-uri "concurrent-ruby" version))
+ (sha256
+ (base32
+ "183lszf5gx84kcpb779v6a2y0mx9sssy8dgppng1z9a505nj1qcf"))))
+ (build-system ruby-build-system)
+ (arguments `(#:tests? #f)); No rakefile
+ (home-page "https://github.com/ruby-concurrency/concurrent-ruby")
+ (synopsis "Concurrency tools for Ruby")
+ (description "This gem provides concurrency tools for Ruby. It provides
+a library of common thread-safe types and data-structures as well as abstractions
+for concurrency and communication between threads.")
+ (license license:expat)))
+
(define-public ruby-highline
(package
(name "ruby-highline")