aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-01-09 15:26:58 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-03-28 22:22:24 -0400
commit2f7c92e247c85fdf0d7957c22464e4a50248f5d8 (patch)
tree4728dc5c341402d46143741a251260960cf8f96a /gnu
parent6414c5a139c57b9bdde12e51e36b40050eb77e45 (diff)
downloadguix-2f7c92e247c85fdf0d7957c22464e4a50248f5d8.tar.gz
guix-2f7c92e247c85fdf0d7957c22464e4a50248f5d8.zip
gnu: ruby-concurrent: Replace with ruby-concurrent-ruby.
* gnu/packages/ruby.scm (ruby-concurrent): Delete package, and define it as a deprecated alias to ruby-concurrent-ruby instead.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/ruby.scm77
1 files changed, 6 insertions, 71 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 2d40609d7d..ffb87cd0c5 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -10403,77 +10403,6 @@ call.")
(home-page "https://github.com/travisjeffery/timecop")
(license license:expat)))
-(define-public ruby-concurrent
- (package
- (name "ruby-concurrent")
- (version "1.1.5")
- (source
- (origin
- (method git-fetch)
- ;; Download from GitHub because the rubygems version does not contain
- ;; Rakefile.
- (uri (git-reference
- (url "https://github.com/ruby-concurrency/concurrent-ruby")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "193q2k47vk7qdvv9hlhmmdxgy91xl4imapyk1ijdg9vgf46knyzj"))))
- (build-system ruby-build-system)
- (arguments
- `(#:test-target "ci"
- #:phases
- (modify-phases %standard-phases
- (add-before 'replace-git-ls-files 'remove-extra-gemspecs
- (lambda _
- ;; Delete extra gemspec files so 'first-gemspec' chooses the
- ;; correct one.
- (delete-file "concurrent-ruby-edge.gemspec")
- (delete-file "concurrent-ruby-ext.gemspec")
- #t))
- (replace 'replace-git-ls-files
- (lambda _
- ;; XXX: The default substitution made by this phase is not fully
- ;; compatible with "git ls-files". The latter produces file names
- ;; such as "lib/foo", whereas ruby-build-system uses "find . [...]"
- ;; which gives "./lib/foo". That difference in turn breaks the
- ;; comparison against a glob pattern in this script.
- (substitute* "concurrent-ruby.gemspec"
- (("git ls-files") "find * -type f | sort"))
- #t))
- (add-before 'build 'remove-jar-from-gemspec
- (lambda _
- ;; The gemspec wants to include a JAR file that we do not build
- ;; nor need.
- (substitute* "concurrent-ruby.gemspec"
- (("'lib/concurrent/concurrent_ruby.jar'")
- ""))
- #t))
- (add-before 'build 'remove-rake_compiler_dock-dependency
- (lambda _
- ;; This library is only used when building for non-MRI targets.
- (substitute* "Rakefile"
- (("require 'rake_compiler_dock'")
- ""))
- #t))
- (add-before 'check 'remove-timecop-dependency
- ;; Remove timecop-dependent tests as having timecop as a depedency
- ;; causes circular depedencies.
- (lambda _
- (delete-file "spec/concurrent/executor/timer_set_spec.rb")
- (delete-file "spec/concurrent/scheduled_task_spec.rb")
- #t)))))
- (native-inputs
- (list ruby-rake-compiler ruby-rspec))
- (synopsis "Concurrency tools for Ruby")
- (description
- "This library provides modern concurrency tools including agents,
-futures, promises, thread pools, actors, supervisors, and more. It is
-inspired by Erlang, Clojure, Go, JavaScript, actors and classic concurrency
-patterns.")
- (home-page "http://www.concurrent-ruby.com")
- (license license:expat)))
-
(define-public ruby-concurrent-ruby
(package
(name "ruby-concurrent-ruby")
@@ -10512,6 +10441,12 @@ patterns.")
(home-page "https://github.com/ruby-concurrency/concurrent-ruby")
(license license:expat)))
+;;; The 'gem' is called 'concurrent-ruby'; reversing its name was confusing
+;;; and failed to be picked by the gem importer (which led to this newer
+;;; package).
+(define-public ruby-concurrent
+ (deprecated-package "ruby-concurrent" ruby-concurrent-ruby))
+
(define-public ruby-pkg-config
(package
(name "ruby-pkg-config")