aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-16 17:13:06 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:18:35 +0200
commit2b628008ac3ac686f9d50cc2b8d67a534567f385 (patch)
tree956530f762811af76c0b3131c0a3b863dcd0adce /gnu
parent5763c204de777e8b9b8fac3d5fb2327157f1e13d (diff)
downloadguix-2b628008ac3ac686f9d50cc2b8d67a534567f385.tar.gz
guix-2b628008ac3ac686f9d50cc2b8d67a534567f385.zip
gnu: Add texlive-latex2man.
* gnu/packages/tex.scm (texlive-latex2man): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 442b3ba61a..df0993016a 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -2543,6 +2543,36 @@ this is to print on (notional) small paper, and then to magnify the result;
the script calculates the settings for various font and paper sizes.")
(license license:asl2.0)))
+(define-public texlive-latex2man
+ (package
+ (name "texlive-latex2man")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/info/latex2man.info"
+ "doc/man/man1/latex2man.1"
+ "doc/man/man1/latex2man.man1.pdf"
+ "doc/support/latex2man/"
+ "scripts/latex2man/"
+ "tex/latex/latex2man/")
+ (base32
+ "0c5pfnhw80fh132k2dmj3qdjgvl9dm6xzv55f54g2wlswpzlinis")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (arguments (list #:link-scripts #~(list "latex2man")))
+ (inputs (list perl))
+ (home-page "https://ctan.org/pkg/latex2man")
+ (synopsis "Translate LaTeX-based manual pages into Unix man format")
+ (description
+ "Latex2man is a tool to translate UNIX manual pages written with LaTeX
+into the troff format understood by the UNIX man(1) command. Alternatively
+HTML, TexInfo, or LaTeX code can be produced too. Output of parts of the text
+may be supressed using the conditional text feature (for this, LaTeX
+generation may be used). There is a LaTeX package (@file{latex2man.sty}) for
+writing the man page and a Perl script, @command{latex2man} that does the
+actual translation.")
+ (license license:lppl1.0+)))
+
(define-public texlive-tex-ini-files
(package
(name "texlive-tex-ini-files")