aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2019-09-24 19:21:59 +0200
committerPierre Neidhardt <mail@ambrevar.xyz>2019-09-24 19:21:59 +0200
commitf95ec65be394538c9ec848e502a37f1c3ec21157 (patch)
treedbbb419802819b4a1d5f87966fec63e74e7f2a54 /gnu/packages
parent24f7bac02a70257a7cd1bb2e1ec35d7cc753057e (diff)
downloadguix-f95ec65be394538c9ec848e502a37f1c3ec21157.tar.gz
guix-f95ec65be394538c9ec848e502a37f1c3ec21157.zip
gnu: openmw: Use OpenMW's fork of openscenegraph.
* gnu/packages/game-development.scm (openmw)[inputs]: Replace openscenegraph with openmw-openscenegraph.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/game-development.scm36
1 files changed, 35 insertions, 1 deletions
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index bb4c1d26bb..ee9e63ea29 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -1109,6 +1109,40 @@ of use.")
'("ogre"))))
(synopsis "Fast, flexible and simple GUI (OpenGL backend)")))
+(define openmw-openscenegraph
+ ;; OpenMW prefers its own fork of openscenegraph:
+ ;; https://wiki.openmw.org/index.php?title=Development_Environment_Setup#OpenSceneGraph.
+ (let ((commit "36a962845a2c87a6671fd822157e0729d164e940"))
+ (package
+ (inherit openscenegraph)
+ (version (git-version "3.6" "1" commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/OpenMW/osg/")
+ (commit commit)))
+ (file-name (git-file-name (package-name openscenegraph) version))
+ (sha256
+ (base32
+ "05yhgq3qm5q277y32n5sf36vx5nv5qd3zlhz4csgd3a6190jrnia"))))
+ (arguments
+ (substitute-keyword-arguments (package-arguments openscenegraph)
+ ((#:configure-flags flags)
+ ;; As per the above wiki link, the following plugins are enough:
+ `(append
+ '("-DBUILD_OSG_PLUGINS_BY_DEFAULT=0"
+ "-DBUILD_OSG_PLUGIN_OSG=1"
+ "-DBUILD_OSG_PLUGIN_DDS=1"
+ "-DBUILD_OSG_PLUGIN_TGA=1"
+ "-DBUILD_OSG_PLUGIN_BMP=1"
+ "-DBUILD_OSG_PLUGIN_JPEG=1"
+ "-DBUILD_OSG_PLUGIN_PNG=1"
+ "-DBUILD_OSG_DEPRECATED_SERIALIZERS=0"
+ ;; The jpeg plugin requires conversion between integers and booleans
+ "-DCMAKE_CXX_FLAGS=-fpermissive")
+ ,flags)))))))
+
(define-public openmw
(package
(name "openmw")
@@ -1137,7 +1171,7 @@ of use.")
("libxt" ,libxt)
("mygui" ,mygui-gl) ; OpenMW does not need Ogre.
("openal" ,openal)
- ("openscenegraph" ,openscenegraph)
+ ("openscenegraph" ,openmw-openscenegraph)
("qtbase" ,qtbase)
("sdl" ,sdl2)
("unshield" ,unshield)))
/guix/commit/gnu/packages/kde.scm?id=360000169371a4c801cdd2e694f40c813baa2053'>gnu: libkomparediff2: Update to 17.12.1...* gnu/packages/kde.scm(libkomparediff2): Update to 17.12.1. [source] Switch to KDE mirror, use mirror://kde scheme. Hartmut Goebel 2018-02-18gnu: libksysguard: Update to 5.11.5....* gnu/packages/kde.scm (libksysguard: Update to 5.11.5). Hartmut Goebel 2018-02-15gnu: Add kholidays....* gnu/packages/kde.scm(kholidays): New variable. Hartmut Goebel 2018-01-13gnu: krita: Update to 3.3.3....* gnu/packages/kde.scm (krita): Update to 3.3.3. Leo Famulari 2018-01-03gnu: krita: Add comment about the wrapper....* gnu/packages/kde.scm (krita): Add comment. Leo Famulari 2018-01-03gnu: krita: Ensure icons are found at runtime....Fixes <https://bugs.gnu.org/29905>. * gnu/packages/kde.scm (krita)[arguments]: Set the QT_PLUGIN_PATH in a new 'wrap-executable' phase. Leo Famulari 2018-01-02gnu: libksysguard: Update to 5.11.4....* gnu/packages/kde.scm (libksysguard): Update to 5.11.4. Tobias Geerinckx-Rice 2017-12-16gnu: krita: Enhance krita....* gnu/packages/kde.scm (krita)[inputs]: Add libjpeg-turbo, ilmbase and openexr. [native-inputs]: Add vc. [arguments]: Set path to headers for ilmbase. Signed-off-by: Kei Kebreau <kkebreau@posteo.net> Mark Meyer 2017-12-12gnu: Add krita....* gnu/packages/kde.scm (krita): New variable. Signed-off-by: Kei Kebreau <kkebreau@posteo.net> Mark Meyer 2017-11-05gnu: libksysguard: Update to 5.11.2....* gnu/packages/kde.scm (libksysguard): Update to 5.11.2. Hartmut Goebel 2017-10-08gnu: kdevelop: Do not hardcode user profile locations in wrapper....* gnu/packages/kde.scm (kdevelop): [arguments]: Do not add ${HOME}/.guix-profile/{share,lib/plugins} to XDG_DATA_DIRS and QT_PLUGIN_PATH when wrapping the executable. Thomas Danckaert 2017-08-30gnu: kdevelop: Update to 5.1.2....* gnu/packages/kde.scm (kdevelop, kdevplatform): Update to 5.1.2. Thomas Danckaert 2017-08-24gnu: libksysguard: Enable more tests (not all working yet)....* gnu/packages/kde.scm (libksysguard)[arguments] <#:phases>'check-setup': Set QT_QPA_PLATFORM=offscreen. <#:phases>'check': Enable all tests except of the failing one. Hartmut Goebel 2017-08-18gnu: libksysguard: Update to 5.10.4....* gnu/packages/kde.scm (libksysguard ): Update to 5.10.4. Efraim Flashner 2017-06-15gnu: kdevelop: Update to 5.1.1....* gnu/packages/kde.scm (kdevelop): Update to 5.1.1. [arguments]: Set QT_QPA_PLATFORM_PLUGIN_PATH during the wrap-executable phase. (kdevplatform): Update to 5.1.1. Thomas Danckaert 2017-06-08gnu: kde.scm, kde-frameworks.scm: Add and update comments....* gnu/packages/kde-frameworks.scm (kpackage,plasma-framework)[arguments]: Update comment (number of failed tests). (kdeclarative)[arguments]<#:phases>: Update comment. (bluez-qt,knotifications,kpty,ktexteditor,ktextwidgets,solid)[inputs]: Add a todo comment. (kguiaddons): Add a todo comment. (phonon)[native-inputs]: Add a todo comment. * gnu/packages/kde-frameworks.scm (kauth)[arguments]<#:phases>: Add a todo comment. Hartmut Goebel 2017-05-04gnu: qca: Update to 2.1.3....* gnu/packages/kde.scm (qca): Update to 2.1.3. [home-page]: Use new home-page. Efraim Flashner