aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-04-22 16:10:39 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2021-04-22 16:11:04 +0200
commitf93a2dd5403600fea28790692732d310de837762 (patch)
tree573c5d6c0de88ba60d6d6a5d0a2b16a7b77c83e0 /gnu/packages
parent78fb1dbca21ecf2ee3084f89d0b7ddb2e615a3a3 (diff)
downloadguix-f93a2dd5403600fea28790692732d310de837762.tar.gz
guix-f93a2dd5403600fea28790692732d310de837762.zip
gnu: wireshark: Update to 3.4.5 [security fixes].
* gnu/packages/networking.scm (wireshark): Update to 3.4.5.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/networking.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index f7557fc331..69b223fb66 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -1421,14 +1421,14 @@ of the same name.")
(define-public wireshark
(package
(name "wireshark")
- (version "3.4.4")
+ (version "3.4.5")
(source
(origin
(method url-fetch)
(uri (string-append "https://www.wireshark.org/download/src/wireshark-"
version ".tar.xz"))
(sha256
- (base32 "0aad3m8nh4i75dgjs68217135bzqmhmlgjklmpjh1ihmjwgd373j"))))
+ (base32 "0cyk8nqws9gp8p2ywszbynh8vawivnbhw60dhmy21qd1038sy6ny"))))
(build-system cmake-build-system)
(arguments
`(#:phases
bff'>etc: Break long lines in commit messages.Ricardo Wurmus * etc/committer.scm.in (break-string): New procedure. (change-commit-message): Use it. 2021-04-12etc/committer: Add missing newline.Morgan Smith * etc/committer.scm.in (main): Add newline to message. Signed-off-by: Ricardo Wurmus <rekado@elephly.net> 2021-04-12etc/committer: Use git plumbing instead of porcelain.Morgan Smith * etc/committer.scm.in (diff-info): Use "git diff-files" instead of "git diff". (old-sexp): Use "git cat-file" instead of "git show". Signed-off-by: Ricardo Wurmus <rekado@elephly.net> 2021-04-08etc/committer: Disable diff colors.Ricardo Wurmus Reported by: morgansmith on IRC. * etc/committer.scm.in (diff-info): Invoke "git diff" with "--no-color". 2021-04-08etc/committer: Recompute hunks before processing changes.Ricardo Wurmus * etc/committer.scm.in (main): Re-evaluate diff-info after processing insertions. 2021-04-08etc/committer: Record minimal context for hunks to avoid problems.Ricardo Wurmus With zero context new definitions would be applied to the wrong location in the file. More context lines lead to larger hunks, though, so we use just one line of context. * etc/committer.scm.in (diff-info): Invoke "git diff" with one line of context. [info]: Merge line break and first line. (lines-to-first-change): New procedure. (old-sexp, new-sexp): Use it. 2021-04-08etc/committer: Define delay duration as a variable.Ricardo Wurmus * etc/committer.scm.in (%delay): New variable. (main): Use it. 2021-04-08etc/committer: Handle package additions.Ricardo Wurmus * etc/committer.scm.in (<hunk>)[diff]: Rename this field... [diff-lines]: ...to this. [definition?]: New field. (hunk->patch): Join diff lines. (diff-info): Do not join diff lines; record whether a hunk is a new definition. (commit-message): Rename this procedure... (change-commit-message): ...to this. (add-commit-message): New procedure. (main): Handle new package definitions before changes. 2020-10-06etc: committer: Use EQUAL? instead of EQ? for differences.Ricardo Wurmus * etc/committer.scm.in (commit-message): Use EQUAL? instead of EQ? to compute differences because not all inputs may be symbols; some could be expressions. 2020-06-16etc: Add committer script.Ricardo Wurmus * etc/committer.scm.in: New file. * configure.ac: Configure it.