aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-13 10:40:33 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:17:58 +0200
commiteb3c818ede06eaae2917e9bbe0a75953120b4a94 (patch)
treed6836772e37827efaeb18a1d8d6a6e2b85897b7e /gnu/packages
parent5978c718b24f28e3adbeae102c44eddaa2c6e354 (diff)
downloadguix-eb3c818ede06eaae2917e9bbe0a75953120b4a94.tar.gz
guix-eb3c818ede06eaae2917e9bbe0a75953120b4a94.zip
gnu: Add texlive-tikz-sfc.
* gnu/packages/tex.scm (texlive-tikz-sfc): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/tex.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 695b5aa564..733032b4e4 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -4801,6 +4801,30 @@ symbols are also included mainly to be used in presentations, particularly
with the @code{beamer} package.")
(license license:lppl1.0+)))
+(define-public texlive-tikz-sfc
+ (package
+ (name "texlive-tikz-sfc")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/tikz-sfc/" "tex/latex/tikz-sfc/")
+ (base32
+ "0blgyqvmnbwafx85mz4gkyhk0g0zqfmsd98gm3h794a4jfs3zl31")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/tikz-sfc")
+ (synopsis
+ "Symbols collection for typesetting Sequential Function Chart (SFC)
+diagrams")
+ (description
+ "This package contains a collection of symbols for typesetting Sequential
+Function Chart (SFC) diagrams in agreement with the international standard
+IEC-61131-3/2013. It includes steps (normal and initial), transitions,
+actions and actions qualifiers (with and without time duration). It extends
+the circuit library of TikZ and allows you to draw an SFC diagram in same way
+you would draw any other circuit.")
+ (license license:lppl1.0+)))
+
(define-public texlive-amiri
(package
(name "texlive-amiri")