aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-13 10:38:04 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:17:55 +0200
commitdf4af09f21fc3419c04ba69753e2c767a7fe00bd (patch)
treea58137c2a24f02b89cd0da47f9ed6d276bf60773 /gnu/packages
parente7d87d53aa5078539763b4f8447a501988956776 (diff)
downloadguix-df4af09f21fc3419c04ba69753e2c767a7fe00bd.tar.gz
guix-df4af09f21fc3419c04ba69753e2c767a7fe00bd.zip
gnu: Add texlive-tikz-nef.
* gnu/packages/tex.scm (texlive-tikz-nef): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/tex.scm49
1 files changed, 49 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 660aa63549..faa9690290 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -4601,6 +4601,55 @@ height of the object. It calculates the position and height of the image, and
also displays the notable rays.")
(license license:lppl1.3c)))
+(define-public texlive-tikz-nef
+ (package
+ (name "texlive-tikz-nef")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/tikz-nef/" "tex/latex/tikz-nef/")
+ (base32
+ "18b2452hfcndqhljq2hn437z6myc45hn62s4bnnjb0f3xnayq1qr")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/tikz-nef")
+ (synopsis "Create diagrams for neural networks")
+ (description
+ "The @code{nef} TikZ library provides predefined styles and shapes to
+create diagrams for neural networks constructed with the methods of
+the Neural Engineering Framework (NEF). The following styles are
+supported:
+@itemize
+@item @code{ea}: ensemble array,
+@item @code{ens}: ensemble,
+@item @code{ext}: external input or output,
+@item @code{inhibt}: inhibitory connection,
+@item @code{net}: network,
+@item @code{pnode}: pass-through node,
+@item @code{rect}: rectification ensemble,
+@item @code{recurrent}: recurrent connection.
+@end itemize")
+ (license license:expat)))
+
+(define-public texlive-tikz-network
+ (package
+ (name "texlive-tikz-network")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/tikz-network/"
+ "tex/latex/tikz-network/")
+ (base32
+ "1bs08sxxps4kjvgv53lc07ihkcaz2v1ygdc16vn46yy5dp16w2sz")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/tikz-network")
+ (synopsis "Draw networks with TikZ")
+ (description
+ "This package allows the creation of images of complex networks that are
+seamlessly integrated into the underlying LaTeX files.")
+ (license license:gpl3+)))
+
(define-public texlive-amiri
(package
(name "texlive-amiri")