aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-02-18 19:32:48 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2018-02-19 06:00:29 +0100
commitb7fd3e96c7b6ccf7f6f9949b5a263753b4fee50e (patch)
tree330e0ec6801d2b19b77e2f7058a0b5736279f8fb /gnu/packages
parent57774ae150dad563767d6d573e206b45fce4683c (diff)
downloadguix-b7fd3e96c7b6ccf7f6f9949b5a263753b4fee50e.tar.gz
guix-b7fd3e96c7b6ccf7f6f9949b5a263753b4fee50e.zip
gnu: lsof: Update phase style.
* gnu/packages/lsof.scm (lsof)[arguments]: Substitute INVOKE for SYSTEM* and end phases with #t.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/lsof.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/lsof.scm b/gnu/packages/lsof.scm
index f9e9759cf2..fcd5c2e1c7 100644
--- a/gnu/packages/lsof.scm
+++ b/gnu/packages/lsof.scm
@@ -69,7 +69,8 @@
(lambda _
(setenv "LSOF_CC" "gcc")
(setenv "LSOF_MAKE" "make")
- (zero? (system* "./Configure" "linux"))))
+ (invoke "./Configure" "linux")
+ #t))
(replace 'install
(lambda* (#:key outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out")))
zlib" and "guile-lzlib", [inputs]: remove "zlib" and "lzlib", [propagated-inputs]: ditto, [arguments]: add "guile-zlib" and "guile-lzlib" to Guile load path. * guix/config.scm.in (%libz, %liblz): Remove them. * guix/lzlib.scm: Remove it. * guix/man-db.scm: Use (zlib) instead of (guix zlib). * guix/profiles.scm (manual-database): Do not stub (guix config) in imported modules list, instead add "guile-zlib" to the extension list. * guix/scripts/publish.scm: Use (zlib) instead of (guix zlib) and (lzlib) instead of (guix lzlib), (string->compression-type, effective-compression): do not check for zlib and lzlib availability. * guix/scripts/substitute.scm (%compression-methods): Do not check for lzlib availability. * guix/self.scm (specification->package): Add "guile-zlib" and "guile-lzlib" and remove "zlib" and "lzlib", (compiled-guix): remove "zlib" and "lzlib" arguments and add guile-zlib and guile-lzlib to the dependencies, also do not pass "zlib" and "lzlib" to "make-config.scm" procedure, (make-config.scm): remove "zlib" and "lzlib" arguments as well as %libz and %liblz variables. * guix/utils.scm (lzip-port): Use (lzlib) instead of (guix lzlib) and do not check for lzlib availability. * guix/zlib.scm: Remove it. * m4/guix.m4 (GUIX_LIBZ_LIBDIR, GUIX_LIBLZ_FILE_NAME): Remove them. * tests/lzlib.scm: Use (zlib) instead of (guix zlib) and (lzlib) instead of (guix lzlib), and do not check for zlib and lzlib availability. * tests/publish.scm: Ditto. * tests/substitute.scm: Do not check for lzlib availability. * tests/utils.scm: Ditto. * tests/zlib.scm: Remove it. Mathieu Othacehe