aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-13 10:43:45 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:18:01 +0200
commitac5edde4cd69b83a3af9c7dbc85589ce285b444b (patch)
treefcce794b6786ca8e53de6498522a97c3b906e10d /gnu/packages
parent3d5d0eb44f7e4cc96d0fab585e9cc581d518f402 (diff)
downloadguix-ac5edde4cd69b83a3af9c7dbc85589ce285b444b.tar.gz
guix-ac5edde4cd69b83a3af9c7dbc85589ce285b444b.zip
gnu: Add texlive-tikzinclude.
* gnu/packages/tex.scm (texlive-tikzinclude): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/tex.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 23ead1e0a5..aefe1cd816 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -4991,6 +4991,26 @@ images from files and from TikZ pictures. Also, patterns of hexagons and of
rhombi are provided.")
(license license:lppl1.3+)))
+(define-public texlive-tikzinclude
+ (package
+ (name "texlive-tikzinclude")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/tikzinclude/"
+ "source/latex/tikzinclude/"
+ "tex/latex/tikzinclude/")
+ (base32
+ "0mcgzbfvj6pksr18813kpnknkdpzlyi0rncbn9g11ac0g0lyzgqq")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/tikzinclude")
+ (synopsis "Import TikZ images from colletions")
+ (description
+ "The package addresses the problem of importing only one TikZ-image from
+a file holding multiple images.")
+ (license license:lppl1.3+)))
+
(define-public texlive-amiri
(package
(name "texlive-amiri")