aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2024-06-24 11:00:44 +0200
committerGuillaume Le Vaillant <glv@posteo.net>2024-06-29 10:49:57 +0200
commita46908620fac09bd8ccd0f587a27e86035d3b1d7 (patch)
tree2d45cea1cc39bd874686993c5c27beb67eee5be9 /gnu/packages
parent647524d308151ba2e73816616290b062a70eeea7 (diff)
downloadguix-a46908620fac09bd8ccd0f587a27e86035d3b1d7.tar.gz
guix-a46908620fac09bd8ccd0f587a27e86035d3b1d7.zip
gnu: stumpwm: Use a single output.
This is a warkaround for the excess library grafts issue that can prevent stumpwm from working properly. See <https://issues.guix.gnu.org/47115> and <https://issues.guix.gnu.org/62890>. * gnu/packages/wm.scm (stumpwm)[outputs]: Remove "lib" output. [arguments]: Remove references to the "lib" output from phases. (stumpwm+slynk, stumpwm-contrib, sbcl-stumpwm-pamixer, sbcl-stumpwm-ttf-fonts, sbcl-stumpwm-stumptray, sbcl-stumpwm-disk, sbcl-stumpwm-screenshot, sbcl-stumpwm-notify, sbcl-stumpwm-battery-portable)[inputs]: Replace '(stumpwm "lib")' with 'stumpwm'. Change-Id: I3d8f025057965032c40ea833d3ebe62f9700071d
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/wm.scm40
1 files changed, 14 insertions, 26 deletions
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 22ee09d780..505ce09c1a 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -2410,7 +2410,6 @@ wlr-output-management-unstable-v1 protocol.")
(list sbcl-alexandria
sbcl-cl-ppcre
sbcl-clx))
- (outputs '("out" "lib"))
(arguments
(list
#:phases
@@ -2423,12 +2422,12 @@ wlr-output-management-unstable-v1 protocol.")
(add-after 'create-asdf-configuration 'build-program
(lambda* (#:key outputs #:allow-other-keys)
(build-program
- (string-append (assoc-ref outputs "out") "/bin/stumpwm")
+ (string-append #$output "/bin/stumpwm")
outputs
#:entry-program '((stumpwm:stumpwm) 0))))
(add-after 'build-program 'create-desktop-file
(lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
+ (let* ((out #$output)
(xsessions (string-append out "/share/xsessions")))
(mkdir-p xsessions)
(call-with-output-file
@@ -2445,7 +2444,7 @@ wlr-output-management-unstable-v1 protocol.")
out))))))
(add-after 'install 'install-manual
(lambda* (#:key (make-flags '()) outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
+ (let* ((out #$output)
(info (string-append out "/share/info")))
(invoke "./autogen.sh")
(invoke "sh" "./configure" "SHELL=sh")
@@ -2453,8 +2452,7 @@ wlr-output-management-unstable-v1 protocol.")
(install-file "stumpwm.info" info))))
(add-after 'install-manual 'remove-temporary-cache
(lambda* (#:key outputs #:allow-other-keys)
- (delete-file-recursively (string-append (assoc-ref outputs "lib")
- "/.cache")))))))
+ (delete-file-recursively (string-append #$output "/.cache")))))))
(synopsis "Window manager written in Common Lisp")
(description
"Stumpwm is a window manager written entirely in Common Lisp.
@@ -2474,10 +2472,8 @@ productive, customizable lisp based systems.")
(package
(inherit stumpwm)
(name "stumpwm-with-slynk")
- (outputs '("out"))
(inputs
- `(("stumpwm" ,stumpwm "lib")
- ("slynk" ,sbcl-slynk)))
+ (list sbcl-slynk stumpwm))
(arguments
(substitute-keyword-arguments (package-arguments stumpwm)
((#:phases phases)
@@ -2492,8 +2488,7 @@ productive, customizable lisp based systems.")
#:dependencies '("stumpwm" "slynk")
#:dependency-prefixes
(map (lambda (input) (assoc-ref inputs input))
- '("stumpwm" "slynk")))
- #t)))
+ '("stumpwm" "sbcl-slynk"))))))
(delete 'copy-source)
(delete 'build)
(delete 'check)
@@ -2517,7 +2512,7 @@ productive, customizable lisp based systems.")
(base32 "1g8h2vd5qsmaiz6ixlx9ykrv6a08izmkf0js18fvljvznpyhsznz"))))
(build-system asdf-build-system/sbcl)
(inputs
- `(("stumpwm" ,stumpwm "lib")))
+ (list stumpwm))
(home-page "https://github.com/stumpwm/stumpwm-contrib")
(synopsis "StumpWM extra modules")
(description "This package provides extra modules for StumpWM.")
@@ -2562,7 +2557,7 @@ productive, customizable lisp based systems.")
(sha256
(base32
"0djcrr16bx40l7b60d4j507vk5l42fdgmjpgrnk86z1ba8wlqim8"))))
- (inputs (list pamixer `(,stumpwm "lib")))
+ (inputs (list pamixer stumpwm))
(build-system asdf-build-system/sbcl)
(arguments
(list #:asd-systems ''("pamixer")
@@ -2604,8 +2599,7 @@ mouse control mode for StumpWM.")
(inherit stumpwm-contrib)
(name "sbcl-stumpwm-ttf-fonts")
(inputs
- `(("stumpwm" ,stumpwm "lib")
- ("clx-truetype" ,sbcl-clx-truetype)))
+ (list sbcl-clx-truetype stumpwm))
(arguments
'(#:asd-systems '("ttf-fonts")
#:tests? #f
@@ -2717,9 +2711,7 @@ between windows.")
(modify-phases %standard-phases
(add-after 'unpack 'chdir (lambda _ (chdir "modeline/stumptray") #t)))))
(inputs
- `(("stumpwm" ,stumpwm "lib")
- ("xembed" ,sbcl-clx-xembed)
- ("alexandria" ,sbcl-alexandria)))
+ (list sbcl-alexandria sbcl-clx-xembed stumpwm))
(home-page
"https://github.com/stumpwm/stumpwm-contrib/tree/master/modeline/stumptray")
(synopsis "Modeline support for stumptray connectivity")
@@ -2794,9 +2786,7 @@ layouts in StumpWM.")
(add-after 'unpack 'chdir
(lambda _ (chdir "modeline/disk") #t)))))
(inputs
- `(("stumpwm" ,stumpwm "lib")
- ("cl-diskspace" ,sbcl-cl-diskspace)
- ("cl-mount-info" ,sbcl-cl-mount-info)))
+ (list sbcl-cl-diskspace sbcl-cl-mount-info stumpwm))
(home-page "https://github.com/stumpwm/stumpwm-contrib")
(synopsis "StumpWM modeline support to show disk usage")
(description "StumpWM modeline support to show disk usage")
@@ -2844,8 +2834,7 @@ one in Emacs.")
(inherit stumpwm-contrib)
(name "sbcl-stumpwm-screenshot")
(inputs
- `(("stumpwm" ,stumpwm "lib")
- ("zpng" ,sbcl-zpng)))
+ (list sbcl-zpng stumpwm))
(arguments
'(#:asd-systems '("screenshot")
#:tests? #f
@@ -2894,7 +2883,7 @@ modeline.")
(list sbcl-bordeaux-threads
sbcl-dbus
sbcl-xml-emitter
- (list stumpwm "lib")))
+ stumpwm))
(arguments
'(#:asd-systems '("notify")
#:phases
@@ -2914,8 +2903,7 @@ by default.")
(name "sbcl-stumpwm-battery-portable")
(build-system asdf-build-system/sbcl)
(inputs
- (list sbcl-cl-ppcre
- (list stumpwm "lib")))
+ (list sbcl-cl-ppcre stumpwm))
(arguments
'(#:asd-systems '("battery-portable")
#:phases
x Data Service....* gnu/services/guix.scm: New file. * gnu/tests/guix.scm: New file. * gnu/local.mk (GNU_SYSTEM_MODULES): Add both new files. * doc/guix.texi (Guix Services): New section documenting the Guix Data Service. Christopher Baines 2019-09-24Merge branch 'master' into core-updatesLudovic Courtès 2019-09-24doc: Remove more ‘guixsd’ remnants....* doc/guix.texi (Installing Guix in a VM): Use ‘guix-system.img’ as image file name. Tobias Geerinckx-Rice 2019-09-23doc: Fix typo....* doc/guix.texi (Build Systems): Fix/spoil ‘libary’ typo/joke. Tobias Geerinckx-Rice 2019-09-23doc: Explain that '--profile' expects a file name....* doc/guix.texi (Invoking guix package): Explain that the argument to --profile is a file name. Ludovic Courtès 2019-09-23pull: Display channel news....* guix/scripts/pull.scm (display-news-entry) (display-channel-specific-news): New procedures. (display-channel-news): Call it. (display-new/upgraded-packages): Adjust hint message. * doc/guix.texi (Invoking guix pull): Mention it. Ludovic Courtès 2019-09-23channels: Allow news entries to refer to a tag....Suggested by Ricardo Wurmus <rekado@elephly.net>. * guix/channels.scm (<channel-news-entry>)[tag]: New field. (sexp->channel-news-entry): Accept either 'commit' or 'tag' in 'entry' forms. (resolve-channel-news-entry-tag): New procedure. (channel-news-for-commit): Move 'with-repository' form one level higher. Call 'resolve-channel-news-entry-tag' on all the news entries. * guix/tests/git.scm (populate-git-repository): Add clause for 'tag'. * tests/channels.scm ("channel-news, one entry"): Create a tag and add an entry with a tag. Check that the tag is resolved and also visible in the <channel-news-entry> record. * doc/guix.texi (Channels): Mention tags in news entries. Ludovic Courtès 2019-09-23channels: Add support for a news file....* guix/channels.scm (<channel-metadata>)[news-file]: New field. (read-channel-metadata): Set the 'news-file' field. (read-channel-metadata-from-source): Likewise. (<channel-news>, <channel-news-entry>): New record types. (sexp->channel-news-entry, read-channel-news) (channel-news-for-commit): New procedures. * guix/tests/git.scm (populate-git-repository): For 'add', allow CONTENTS to be a procedure. * tests/channels.scm ("channel-news, no news") ("channel-news, one entry"): New tests. * doc/guix.texi (Channels): Document it. Ludovic Courtès 2019-09-21guix package: Add 'guix show' alias....* guix/scripts/show.scm: New file. * Makefile.am (MODULES): Add it. * po/guix/POTFILES.in: Add it. * tests/guix-package-aliases.sh: Add test. * doc/guix.texi (Invoking guix package): Document it and use it in a example. Signed-off-by: Ludovic Courtès <ludo@gnu.org> zimoun 2019-09-18scripts: pull: Add options for generation management...* guix/scripts/pull.scm (%options) Add --roll-back, --switch-generation, --delete-generations (process-generation-change): New function (guix-pull): Execute generation management operations * doc/guix.texi: Document the generation management operations Signed-off-by: Ludovic Courtès <ludo@gnu.org> Konrad Hinsen 2019-09-18doc: Mention the "repository name" for 'guix pack -f docker'....This is a followup to 0074844366381e3056d09492b8b437836c7adb61. * doc/guix.texi (Invoking guix pack): Mention the repository name. Ludovic Courtès 2019-09-18services: Add nftables-service-type....* gnu/services/networking.scm (%default-nftables-ruleset): New variable. (<nftables-configuration>): New record type. (nftables-shepherd-service): New procedure. (nftables-service-type): New service type. * doc/guix.texi (Networking Services): Document it. 宋文武 2019-09-18doc: Add Guix Cookbook....* .gitignore: Update ignore list. * Makefile.am (assert-no-store-file-names): Exclude the cookbook. * bootstrap: Generate po files for cookbook translations. * doc/guix-cookbook.texi: New file. * doc/local.mk (info_TEXINFOS): Add it; add a rule to build cookbook translations. * po/doc/local.mk (DOC_COOKBOOK_PO_FILES): New variable. (EXTRA_DIST): Add cookbook pot file and po files. (doc-po-update-cookbook-%): New target. (doc-pot-update): Also update cookbook pot file. (doc-po-update): Also update cookbook po files. Ricardo Wurmus 2019-09-17Merge branch 'master' into core-updatesLudovic Courtès 2019-09-16services: certbot: Add --manual-public-ip-logging-ok for manual challenges...* gnu/services/certbot.scm (certbot-command): Add --manual-public-ip-logging-ok flag to the certbot command when doing a manual challenge. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Carlo Zancanaro 2019-09-11doc: Actually suggest ‘fc-cache -r’....A follow-up commit to 0cd3e99d64081e958919845ddd01ae8d2fb2d692. * doc/guix.texi (Application Setup): Fix my own typo. Tobias Geerinckx-Rice 2019-09-11doc: Run fc-cache verbosely and delete existing caches....* doc/guix.texi (Application Setup): Suggest ‘fc-cache -rv’ instead of ‘fc-cache -f’. Signed-off-by: Tobias Geerinckx-Rice <me@tobias.gr> Joshua Branson 2019-09-10import: crate: Allow imports of a specific version....* guix/import/crate.scm (crate->guix-package): Add optional 'version' argument and honor it. * guix/scripts/import/crate.scm (guix-import-crate): Assume the first argument is a spec and destructure it with 'package-name->name+version'. Pass both to 'crate->guix-package'. * doc/guix.texi (Invoking guix import): Document it. Co-authored-by: Ludovic Courtès <ludo@gnu.org> Martin Becze 2019-09-08services: ntp: Support different NTP server types and options....* gnu/services/networking.scm (ntp-server-types): New enum. (<ntp-server>): New record type. (ntp-server->string): New procedure. (%ntp-servers): Define in terms of <htp-server> records. Use the first entrypoint server as a pool instead of a list of static servers. This is more resilient since a new server of the pool can be interrogated on every request. Add the 'iburst' options. (ntp-configuration-servers): Define a custom accessor that warns but honors the now deprecated server format. (<ntp-configuration>): Use it. (%openntpd-servers): New variable, (<openntpd-configuration>): Use it, as a pool ('servers' field) instead of a regular server. * tests/networking.scm: New file. * Makefile.am (SCM_TESTS): Register it. * doc/guix.texi: Update documentation. Maxim Cournoyer 2019-09-08doc: Add index to find 'ntpd'....* doc/guix.texi (Networking Services): Add @cindex to find 'ntpd' Maxim Cournoyer 2019-09-08services: ntp: Allow large adjustment by default....This is documented as best practice in `man ntpd', and is required to allow the date to be set correctly when traveling (without having to manually update the hardware clock in the BIOS/UEFI). * gnu/services/networking.scm (<ntp-server>)[allow-large-adjustment?]: Set the default value to #t. * doc/guix.texi (Networking Services): Update documentation. Maxim Cournoyer