aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:tests: Corrupt archive import test is robust against different store prefixes....* tests/store.scm ("import corrupt path"): Set 'index' to #x70. Ludovic Courtès
2017-04-21store: 'GUIX_DAEMON_SOCKET' can now be a URI....* guix/store.scm (%daemon-socket-file): Rename to... (%daemon-socket-uri): ... this. (connect-to-daemon): New procedure. (open-connection): Rename 'file' to 'uri'. Use 'connect-to-daemon' instead of 'open-unix-domain-socket'. * guix/tests.scm (open-connection-for-tests): Rename 'file' to 'uri'. * tests/guix-build.sh: Add tests. * tests/store.scm ("open-connection with file:// URI"): New tests. Ludovic Courtès
2017-03-22tests: Fix 'cond-expand' clause for 2.2/2.0....Fixes a mistake in a9a0227c0127e1813190a7664f7ad858e791480d. * tests/store.scm ("current-build-output-port, UTF-8 + garbage"): Inverse the 'cond-expand' clauses since the 'guile-2.0' feature doesn't exist. Ludovic Courtès
2017-03-15store: Adjust UTF-8 test to Guile 2.2....* tests/store.scm ("current-build-output-port, UTF-8 + garbage"): On Guile 2.2, expect REPLACEMENT CHARACTER instead of '?'. Ludovic Courtès
2017-01-30store: Add 'add-data-to-store'....* guix/serialization.scm (write-bytevector): New procedure. (write-string): Rewrite in terms of 'write-bytevector'. * guix/store.scm (write-arg): Add 'bytevector' case. (add-data-to-store): New procedure, from former 'add-text-to-store'. (add-text-to-store): Rewrite in terms of 'add-data-to-store'. * tests/store.scm ("add-data-to-store"): New test. Ludovic Courtès
2017-01-15daemon: Client settings no longer override daemon settings...
-rw-r--r--gnu/packages/lisp-xyz.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 8f98627a5a..f03b415529 100644
--- a/2016-12-08
store: 'open-connectio
@@ -21793,3 +21793,35 @@ introduces and explains filtered functions in detail.")
(define-public ecl-filtered-functions
(sbcl-package->ecl-package sbcl-filtered-functions))
+
+(define-public sbcl-defstar
+ (let ((commit "132829dac9f84fa7202a0c5793aa6accb8d2662a"))
+ (package
+ (name "sbcl-defstar")
+ (version (git-version "1.0.0" "1" commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "http://bitbucket.org/eeeickythump/defstar/")
+ (commit commit)))
+ (file-name (git-file-name "cl-defstar" version))
+ (sha256
+ (base32 "0n6m3aqvdfnsrhlhqjcy72d1i55lbkjg13ij5c7vw003p1n78wxi"))))
+ (build-system asdf-build-system/sbcl)
+ (home-page "http://bitbucket.org/eeeickythump/defstar/")
+ (synopsis "Easy inline (return) type declarations for functions")
+ (description
+ "Defstar is a collection of Common Lisp macros that can be used in
+place of @code{defun}, @code{defmethod}, @code{defgeneric}, @code{defvar},
+@code{defparameter}, @code{flet}, @code{labels}, @code{let*} and
+@code{lambda}. Each macro has the same name as the form it replaces, with a
+star added at the end, e.g. @code{defun}. (the exception is the @code{let*}
+replacement, which is called @code{*let}).")
+ (license license:gpl3))))
+
+(define-public cl-defstar
+ (sbcl-package->cl-source-package sbcl-defstar))
+
+(define-public ecl-defstar
+ (sbcl-package->ecl-package sbcl-defstar))