aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-13 10:36:33 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:17:54 +0200
commit8d696f27ea0fead92664951300caea5f82502b9f (patch)
tree4bcebbccac6793320d27215ece038172cb088b7c /gnu/packages
parent5b5df6660b8d5abf529726e01760b26589e800c1 (diff)
downloadguix-8d696f27ea0fead92664951300caea5f82502b9f.tar.gz
guix-8d696f27ea0fead92664951300caea5f82502b9f.zip
gnu: Add texlive-tikz-ladder.
* gnu/packages/tex.scm (texlive-tikz-ladder): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/tex.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 15fa572868..1199c09643 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -4514,6 +4514,29 @@ considered as an upgrade and extension of Andreas W. Wieland's @code{karnaugh}
package towards TikZ supporting.")
(license license:lppl1.0+)))
+(define-public texlive-tikz-ladder
+ (package
+ (name "texlive-tikz-ladder")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/tikz-ladder/"
+ "tex/latex/tikz-ladder/")
+ (base32
+ "1fkq7z58h7g71ag4j77vy87hqgpp5q8qvw7kv1pmkff7ycrj8alw")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/tikz-ladder")
+ (synopsis "Draw ladder diagrams using TikZ")
+ (description
+ "The @code{tikz-ladder} package contains a collection of symbols for
+typesetting ladder diagrams (PLC program) in agreement with the international
+standard IEC-61131-3/2013. It includes blocks (for representing functions and
+function blocks) besides contacts and coils. It extends the circuit library
+of TikZ and allows you to draw a ladder diagram in the same way as you would
+draw any other circuit.")
+ (license license:lppl1.0+)))
+
(define-public texlive-amiri
(package
(name "texlive-amiri")