aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMartin Becze <mjbecze@riseup.net>2019-10-01 17:37:03 -0400
committerEfraim Flashner <efraim@flashner.co.il>2020-06-15 00:08:56 +0300
commit4b52722838fa41bcc8e0344d2766d7130c203c92 (patch)
treef44d1be1aa13dcdc2c0ecf748984dcf547e3ed5d /gnu/packages
parent535581a72a3e3ec2fbb9a875be99a7455875bbcf (diff)
downloadguix-4b52722838fa41bcc8e0344d2766d7130c203c92.tar.gz
guix-4b52722838fa41bcc8e0344d2766d7130c203c92.zip
gnu: Add go-golang-org-x-oauth2.
* gnu/packages/golang.scm (go-golang-org-x-oauth2): New variable. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/golang.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index a631ad4285..632769b769 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -811,6 +811,33 @@ time.")
(home-page "https://godoc.org/golang.org/x/time/rate")
(license license:bsd-3))))
+(define-public go-golang-org-x-oauth2
+ (let ((commit "0f29369cfe4552d0e4bcddc57cc75f4d7e672a33")
+ (revision "1"))
+ (package
+ (name "go-golang-org-x-oauth2")
+ (version (git-version "0.0.0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://go.googlesource.com/oauth2")
+ (commit commit)))
+ (file-name (string-append "go.googlesource.com-oauth2-"
+ version "-checkout"))
+ (sha256
+ (base32
+ "06jwpvx0x2gjn2y959drbcir5kd7vg87k0r1216abk6rrdzzrzi2"))))
+ (build-system go-build-system)
+ (arguments
+ `(#:import-path "golang.org/x/oauth2"))
+ (propagated-inputs
+ `(("go-golang-org-x-net" ,go-golang-org-x-net)))
+ (home-page "https://go.googlesource.com/oauth2")
+ (synopsis "Client implementation of the OAuth 2.0 spec")
+ (description "This package contains a client implementation for OAuth 2.0
+ spec in Go.")
+ (license license:bsd-3))))
+
(define-public go-github-com-burntsushi-toml
(package
(name "go-github-com-burntsushi-toml")
sh?id=ee75e80c05127020188b93d402d1d70b102eaacf'>tests: Skip 'guix-pack.sh'....This works around a regression introduced in commit 66e9944e078cbb9e0d618377dd6df6e639640efa while waiting for a proper fix. * tests/guix-pack.sh: Add "exit 77". Ludovic Courtès 2018-05-19tests: Skip 'tests/guix-pack.sh' when networking is missing....The test could fail because "static-binaries.tar.xz" is missing, for instance. * tests/guix-pack.sh: Require a network connection to be on the safe side. This reverts part of 47a60325ca650e8fc1a291c8655b4297f4de8deb. Ludovic Courtès 2018-05-10pack: Add '--relocatable'....* gnu/packages/aux-files/run-in-namespace.c: New file. * Makefile.am (AUX_FILES): Add it. * guix/scripts/pack.scm (<c-compiler>): New record type. (c-compiler, bootstrap-c-compiler, c-compiler-compiler): New procedures. (self-contained-tarball): Use 'relative-file-name' for the SOURCE -> TARGET symlink. (docker-image): Add 'defmod' to please Geiser. (wrapped-package, map-manifest-entries): New procedures. (%options, show-help): Add --relocatable. (guix-pack): Honor it. Ludovic Courtès 2018-05-07pack: Fix handling of '-e'....Fixes a regression introduced in aad16cc1965ab3488449c262455eb29b15c77e95. Reported by Julien Lepiller. * guix/scripts/pack.scm (guix-pack)[manifest-from-args]: In 'match-lambda', add clause for single packages. * tests/guix-pack.sh: Add test for '-e'. Ludovic Courtès 2018-05-07pack: Honor package transformation options....Previously they would silently be ignored. * guix/scripts/pack.scm (guix-pack)[manifest-from-args]: Add 'store' parameter. Call 'options->transformation' and use it. Move 'with-store' and 'parameterize' around the 'let'. * tests/guix-pack.sh: Add test using '--with-source'. Ludovic Courtès 2018-05-07pack: Adjust test to cope with GC'd profiles....Previous "test -x opt/gnu/bin/guile" would fail if the store item "opt/gnu/bin" points to had been GC'd. * tests/guix-pack.sh: Replace "test -x" with "test -L" to deal with store items that have been reclaimed. Ludovic Courtès 2018-03-24tests: Add tests for "guix pack"....* guix/scripts/pack.scm (bootstrap-xz): New variable. (%options) <--bootstrap>: New option. (show-help): Document the new --bootstrap option. (guix-pack): When --bootstrap is specified, use the bootstrap Guile, tar, and xz to build the pack, and do not use any profile hooks or locales. * doc/guix.texi (Invoking guix pull): Document the new --bootstrap option. * tests/guix-pack.sh: New file. * Makefile.am (SH_TESTS): Add guix-pack.sh. * gnu/packages/package-management.scm (guix) <inputs>: Add util-linux. Chris Marusich