aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/ruby.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-03-08 16:14:21 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-03-28 22:22:20 -0400
commitefa5230acf5612c8523474a7eb1f9f005bd5a668 (patch)
tree32b3a30691297fc26e3df3ddcf7347bec045213a /gnu/packages/ruby.scm
parent5acb5fcccd24361f9d953a0c291cb1d1982b3540 (diff)
downloadguix-efa5230acf5612c8523474a7eb1f9f005bd5a668.tar.gz
guix-efa5230acf5612c8523474a7eb1f9f005bd5a668.zip
gnu: Add ruby-selenium-webdriver.
* gnu/packages/ruby.scm (ruby-selenium-webdriver): New variable.
Diffstat (limited to 'gnu/packages/ruby.scm')
-rw-r--r--gnu/packages/ruby.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 64d6e9de16..9ddfcc2ba0 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -13492,6 +13492,31 @@ Faraday-based API wrappers.")
Dashboard. It is a Ruby Client library for IRIS / BBS API.")
(license license:expat)))
+(define-public ruby-selenium-webdriver
+ (package
+ (name "ruby-selenium-webdriver")
+ (version "4.8.5")
+ (source (origin
+ (method url-fetch)
+ (uri (rubygems-uri "selenium-webdriver" version))
+ (sha256
+ (base32
+ "0wh44vpsyz4mgyq4h482prgiv7hqa5jsj4i7i5hnvv39jb0rfiwm"))))
+ (build-system ruby-build-system)
+ ;; FIXME: The gem release lacks test files, and the git checkout lacks
+ ;; JavaScript source that is generated using Bazel, which isn't available
+ ;; in Guix yet, so disable the test suite for now.
+ (arguments (list #:tests? #f))
+ (propagated-inputs (list ruby-rexml ruby-rubyzip ruby-websocket))
+ (synopsis "Selenium browser automation bindings for Ruby")
+ (description "Selenium implements the W3C WebDriver protocol to automate
+popular browsers. It aims to mimic the behaviour of a real user as it
+interacts with the application's HTML. It's primarily intended for web
+application testing, but any web-based task can be automated. This package
+provides the Ruby bindings of Selenium.")
+ (home-page "https://www.selenium.dev/")
+ (license license:asl2.0)))
+
(define-public ruby-sentry-core
(package
(name "ruby-sentry-core")