aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/recutils.scm
diff options
context:
space:
mode:
authorDavid Thompson <dthompson2@worcester.edu>2014-09-02 19:06:45 -0400
committerDavid Thompson <dthompson2@worcester.edu>2014-09-03 07:47:47 -0400
commit52bd0810a86396e961ca4c92f7e9e5ea0e8c547b (patch)
tree097ee093eda1669a5d5e6c7c0eda2b95c213248f /gnu/packages/recutils.scm
parentb4f5e0e87c112bd4b8425be0c17524ce9c2a85ca (diff)
downloadguix-52bd0810a86396e961ca4c92f7e9e5ea0e8c547b.tar.gz
guix-52bd0810a86396e961ca4c92f7e9e5ea0e8c547b.zip
gnu: Add postgresql.
* gnu/packages/postgresql.scm: New file. * gnu-system.am (GNU_SYSTEM_MODULES): Add it.
Diffstat (limited to 'gnu/packages/recutils.scm')
0 files changed, 0 insertions, 0 deletions
d' style='width: 72.7%;'/>
1 files changed, 8 insertions, 3 deletions
diff --git a/gnu/build/file-systems.scm b/gnu/build/file-systems.scm
index ee8e8146b2..c468144170 100644
--- a/gnu/build/file-systems.scm
+++ b/gnu/build/file-systems.scm
@@ -44,6 +44,7 @@
read-partition-label
read-partition-uuid
+ read-luks-partition-uuid
bind-mount
@@ -438,6 +439,12 @@ partition field reader that returned a value."
(define read-partition-uuid
(cut read-partition-field <> %partition-uuid-readers))
+(define luks-partition-field-reader
+ (partition-field-reader read-luks-header luks-header-uuid))
+
+(define read-luks-partition-uuid
+ (cut read-partition-field <> (list luks-partition-field-reader)))
+
(define (partition-predicate reader =)
"Return a predicate that returns true if the FIELD of partition header that
was READ is = to the given value."
@@ -454,9 +461,7 @@ was READ is = to the given value."
(partition-predicate read-partition-uuid uuid=?))
(define luks-partition-uuid-predicate
- (partition-predicate
- (partition-field-reader read-luks-header luks-header-uuid)
- uuid=?))
+ (partition-predicate luks-partition-field-reader uuid=?))
(define (find-partition predicate)
"Return the first partition found that matches PREDICATE, or #f if none