aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Kehayias <john.kehayias@protonmail.com>2024-09-08 20:13:33 -0400
committerJohn Kehayias <john.kehayias@protonmail.com>2024-11-05 11:56:31 -0500
commitfda63ca5211137790d633459b63818ac5405691f (patch)
tree6d98e204f01c28a207a88819e67cb0ce8c80a9a2
parente00c621cbbf58a54ca2dd0c7075f154af26bcd54 (diff)
downloadguix-fda63ca5211137790d633459b63818ac5405691f.tar.gz
guix-fda63ca5211137790d633459b63818ac5405691f.zip
gnu: mesa: Update configure flags.
Previously, in 1ed0283fcc12b4b48f5b61be026a7b832d9781dc, mesa's configuration options were altered to use "auto" as needed, while it looks like this was inadvertently changed in 9b2a3e023f7090d19c98e7582220340df3962555. This meant i915 dropped from x86/x86_64. This commit restores the "auto" behavior where it matched our previous driver list (or restored missing drivers). See mesa's meson.build for all options. * gnu/packages/gl.scm (mesa)[arguments]: For gallium-drivers, use "softpipe,llvmpipe" instead of the deprecated "swrast" option. Use "auto" in gallium-drivers and vulkan-drivers where it provides the same driver list (or restores ones dropped from x86/x86_64). Comment on differences from "auto" where we don't use it. Change-Id: I920701f71d19578f4913fda7372273955f0a9847
-rw-r--r--gnu/packages/gl.scm21
1 files changed, 11 insertions, 10 deletions
diff --git a/gnu/packages/gl.scm b/gnu/packages/gl.scm
index 55625ff3c4..1262d25137 100644
--- a/gnu/packages/gl.scm
+++ b/gnu/packages/gl.scm
@@ -361,16 +361,18 @@ also known as DXTn or DXTC) for Mesa.")
#~(list
#$@(cond
((target-aarch64?)
+ ;; This includes more drivers than "auto": asahi, r300, r600
'("-Dgallium-drivers=asahi,etnaviv,freedreno,kmsro,lima,\
-nouveau,panfrost,r300,r600,svga,swrast,tegra,v3d,vc4,virgl,zink"))
+nouveau,panfrost,r300,r600,svga,softpipe,llvmpipe,tegra,v3d,vc4,virgl,zink"))
((target-arm32?)
+ ;; This includes more drivers than "auto": r300, r600
'("-Dgallium-drivers=etnaviv,freedreno,kmsro,lima,nouveau,\
-panfrost,r300,r600,svga,swrast,tegra,v3d,vc4,virgl,zink"))
+panfrost,r300,r600,svga,softpipe,llvmpipe,tegra,v3d,vc4,virgl,zink"))
((or (target-ppc64le?) (target-ppc32?) (target-riscv64?))
- '("-Dgallium-drivers=nouveau,r300,r600,radeonsi,svga,swrast,virgl,zink"))
+ ;; This include more drivers than "auto": svga
+ '("-Dgallium-drivers=nouveau,r300,r600,radeonsi,svga,softpipe,llvmpipe,virgl,zink"))
(else
- '("-Dgallium-drivers=crocus,iris,nouveau,r300,r600,radeonsi,\
-svga,swrast,virgl,zink")))
+ '("-Dgallium-drivers=auto")))
;; Enable various optional features. TODO: opencl requires libclc,
;; omx requires libomxil-bellagio
"-Dplatforms=x11,wayland"
@@ -385,16 +387,15 @@ svga,swrast,virgl,zink")))
"-Dgbm=enabled"
"-Dshared-glapi=enabled"
- ;; Explicitly enable Vulkan on some architectures.
#$@(cond
((or (target-x86-32?) (target-x86-64?))
+ ;; This doesn't include nouveau (which is in "auto") as it needs
+ ;; rust.
+ ;; TODO: Enable nouveau/NVK.
'("-Dvulkan-drivers=intel,intel_hasvk,amd,swrast"))
- ((or (target-ppc64le?) (target-ppc32?))
- '("-Dvulkan-drivers=amd,swrast"))
((target-aarch64?)
+ ;; This differs from "auto" which only includes swrast and intel
'("-Dvulkan-drivers=freedreno,amd,broadcom,swrast"))
- ((target-riscv64?)
- '("-Dvulkan-drivers=amd,swrast"))
(else
'("-Dvulkan-drivers=auto")))