aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2023-03-18 17:35:35 -0400
committerLeo Famulari <leo@famulari.name>2023-03-19 18:00:58 -0400
commitfccf2b2fb569038717e3a8d5d2841742d175cd4b (patch)
tree8465e0c253073b42f085aa0b76015dc8998a5825
parentd683261b23f7647db5f7829106fa5e8f37504101 (diff)
downloadguix-fccf2b2fb569038717e3a8d5d2841742d175cd4b.tar.gz
guix-fccf2b2fb569038717e3a8d5d2841742d175cd4b.zip
gnu: linux-libre 5.15: Update to 5.15.103.
* gnu/packages/linux.scm (linux-libre-5.15-version): Update to 5.15.103. (linux-libre-5.15-pristine-source, deblob-scripts-5.15): Update hashes.
-rw-r--r--gnu/packages/linux.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 9a8963cf2f..59d8c14feb 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -515,17 +515,17 @@ corresponding UPSTREAM-SOURCE (an origin), using the given DEBLOB-SCRIPTS."
;; The "longterm" kernels — the older releases with long-term upstream support.
;; Here are the support timelines:
;; <https://www.kernel.org/category/releases.html>
-(define-public linux-libre-5.15-version "5.15.102")
+(define-public linux-libre-5.15-version "5.15.103")
(define-public linux-libre-5.15-gnu-revision "gnu")
(define deblob-scripts-5.15
(linux-libre-deblob-scripts
linux-libre-5.15-version
linux-libre-5.15-gnu-revision
(base32 "0vj60bra81fmbx3lz924czbhxs4dmvd4d584g9mcs80b7c4q52kg")
- (base32 "1lwmax7078w5p6li1gf66m494xijy4bwa7nm5dlx0k09cfif9q2f")))
+ (base32 "03hwhwbcicwyx5i30d6m715kwgrxz4h21xhk55wnawlk8zhx3r35")))
(define-public linux-libre-5.15-pristine-source
(let ((version linux-libre-5.15-version)
- (hash (base32 "1rh1kcvaz42brn5sxqq00mvy0b36fck196yvxfg7b5qbjzxxs724")))
+ (hash (base32 "01fpipy8skmp4dyxgk8fk9k6hc0w0gvk7mm8f8pm7jhwcf0vlxh8")))
(make-linux-libre-source version
(%upstream-linux-source version hash)
deblob-scripts-5.15)))
;; case, (guix script processes) won't work because: ;; ;; * ARGV0 is qemu-user and not guix-daemon. ;; * Guix-daemon won't be able to stuff client PID in ARGV1 of forked ;; processes. ;; ;; See: https://lists.gnu.org/archive/html/bug-guix/2019-12/msg00017.html. ;; ;; If we detect that we are running with binfmt emulation, all the following ;; tests must be skipped. (define (binfmt-misc?) (let ((pid (getpid)) (cmdline (call-with-input-file "/proc/self/cmdline" get-string-all))) (match (primitive-fork) (0 (dynamic-wind (const #t) (lambda () (exit (not (equal? (call-with-input-file (format #f "/proc/~a/cmdline" pid) get-string-all) cmdline)))) (const #t))) (x (zero? (cdr (waitpid x))))))) (define-syntax-rule (test-assert* description exp) (begin (when (binfmt-misc?) (test-skip 1)) (test-assert description exp))) (test-begin "processes") (test-assert* "not a client" (not (find (lambda (session) (= (getpid) (process-id (daemon-session-client session)))) (daemon-sessions)))) (test-assert* "client" (with-store store (let* ((session (find (lambda (session) (= (getpid) (process-id (daemon-session-client session)))) (daemon-sessions))) (daemon (daemon-session-process session))) (and (kill (process-id daemon) 0) (string-suffix? "guix-daemon" (first (process-command daemon))))))) (test-assert* "client + lock" (with-store store (call-with-temporary-directory (lambda (directory) (let* ((token1 (string-append directory "/token1")) (token2 (string-append directory "/token2")) (exp #~(begin #$(random-text) (mkdir #$token1) (let loop () (unless (file-exists? #$token2) (sleep 1) (loop))) (mkdir #$output))) (guile (package-derivation store %bootstrap-guile)) (drv (run-with-store store (gexp->derivation "foo" exp #:guile-for-build guile))) (thread (call-with-new-thread (lambda () (build-derivations store (list drv))))) (_ (let loop () (unless (file-exists? token1) (usleep 200) (loop)))) (session (find (lambda (session) (= (getpid) (process-id (daemon-session-client session)))) (daemon-sessions))) (locks (daemon-session-locks-held (pk 'session session)))) (call-with-output-file token2 (const #t)) (equal? (list (string-append (derivation->output-path drv) ".lock")) locks)))))) (test-end "processes")