aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-08-27 10:01:27 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-08-27 10:06:33 +0100
commitfc39918530cf93c049109ebd9511de9daa1c8dd2 (patch)
tree8d95aec877677a2160da23846e2f6958b3a8da68
parent5bba9592ec6a99a5289bb5f8afe04b61324da48d (diff)
downloadguix-fc39918530cf93c049109ebd9511de9daa1c8dd2.tar.gz
guix-fc39918530cf93c049109ebd9511de9daa1c8dd2.zip
gnu: go-github-com-prometheus-common: Adjust tests for non x86_64 architecture.
As seen in CI <https://ci.guix.gnu.org/build/5327084/log/raw>. * gnu/packages/prometheus.scm (go-github-com-prometheus-common) [arguments] <#:phases>: Adjust selection of Golang packages during 'check phase. Change-Id: I2dba887aeaf9268df135c1a0483023c08853d0c7
-rw-r--r--gnu/packages/prometheus.scm17
1 files changed, 14 insertions, 3 deletions
diff --git a/gnu/packages/prometheus.scm b/gnu/packages/prometheus.scm
index 449086c566..64c956c0d4 100644
--- a/gnu/packages/prometheus.scm
+++ b/gnu/packages/prometheus.scm
@@ -30,6 +30,7 @@
#:use-module (guix gexp)
#:use-module (guix git-download)
#:use-module (guix packages)
+ #:use-module (guix utils)
#:use-module (gnu packages)
#:use-module (gnu packages golang-build)
#:use-module (gnu packages golang-check)
@@ -241,11 +242,21 @@ Prometheus metrics.")
(when tests?
(with-directory-excursion (string-append "src/" import-path)
(invoke "go" "test" "-v"
- ;; "./config/..." requries
+ ;; Skipp, as it requires
;; <github.com/prometheus/client_golang/prometheus>,
- ;; which introduce cycle.
+ ;; which introduces cycle.
+ ;; "./config/..."
+
+ ;; Some tests fail on non x86_64 architecture:
+ ;; Cannot use 9223372036 (untyped int constant) as int
+ ;; value in ;; struct literal (overflows).
+ ;; Cannot use math.MaxInt64
+ ;; (untyped int constant 9223372036854775807) as int value
+ ;; in argument to HumanizeTimestamp (overflows)
+ #$@(if (target-x86-64?)
+ '("./helpers/...")
+ '())
"./expfmt/..."
- "./helpers/..."
"./model/..."
"./promlog/..."
"./route/..."