aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSpencer King <spencer.king@geneoscopy.com>2024-12-24 23:39:09 +0000
committerLudovic Courtès <ludo@gnu.org>2024-12-28 23:16:05 +0100
commitf9d571044818efa9a4fb28dc4232aa3428d2c9ed (patch)
tree502823e674407880b3a8973ae80a1bb0db687abc
parent194294251feb7ed5b542c92d8cfaa6feba27cf8e (diff)
downloadguix-f9d571044818efa9a4fb28dc4232aa3428d2c9ed.tar.gz
guix-f9d571044818efa9a4fb28dc4232aa3428d2c9ed.zip
gnu: Add julia-precompiletools.
* gnu/packages/julia-xyz.scm (julia-precompiletools): New variable. Change-Id: Id5adc9a28c8985bddf51261a2385b7168ffe8b4e Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/julia-xyz.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index 667d609b6f..419b2dd2ab 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -5107,6 +5107,34 @@ Hessian and g the gradient) may not be a descent direction if H is not positive
definite.")
(license license:expat)))
+(define-public julia-precompiletools
+ (package
+ (name "julia-precompiletools")
+ (version "1.2.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/JuliaLang/PrecompileTools.jl")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "07b69gmgs3zxs86l9g9dymv3sfgncm8sl86sp0ck6xf5ly10phiy"))))
+ (build-system julia-build-system)
+ ;; Tests try to download other repositories
+ ;; Tests try to install "fake" packages
+ (arguments
+ (list
+ #:tests? #f))
+ (propagated-inputs (list julia-preferences))
+ (home-page "https://github.com/JuliaLang/PrecompileTools.jl")
+ (synopsis "Reduce time-to-first-execution of Julia code")
+ (description
+ "This package allows you to reduce the latency of the first
+execution of Julia code. It is applicable to both package developers and
+end users in their personal workflows.")
+ (license license:expat)))
+
(define-public julia-preferences
(package
(name "julia-preferences")