aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoman Scherer <roman@burningswell.com>2024-12-07 19:00:20 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-08 12:32:06 +0000
commitf2ad73507b9a313024893e837aa11774f61b273f (patch)
treed0c46ceb39d6aaa2355fe2b65ca1286d27378406
parent0fae91a5ef6c1d2718ff0f918ac8c71c4ff181e0 (diff)
downloadguix-f2ad73507b9a313024893e837aa11774f61b273f.tar.gz
guix-f2ad73507b9a313024893e837aa11774f61b273f.zip
gnu: python-asyncssh: Disable flaky connection tests.
* gnu/packages/ssh.scm (python-asyncssh): Disable flaky connection tests. Change-Id: If99cc686679fd2c731f3d66a85abe23eff6f1234 Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com>
-rw-r--r--gnu/packages/ssh.scm10
1 files changed, 9 insertions, 1 deletions
diff --git a/gnu/packages/ssh.scm b/gnu/packages/ssh.scm
index 1f33259246..a44976b598 100644
--- a/gnu/packages/ssh.scm
+++ b/gnu/packages/ssh.scm
@@ -833,7 +833,15 @@ shell services and remote host selection.")
;; TODO Test fails for unknown reason
(("(.+)async def test_confirm" all indent)
(string-append indent "@unittest.skip('disabled by guix')\n"
- indent "async def test_confirm")))))
+ indent "async def test_confirm")))
+ (substitute* "tests/test_connection.py"
+ ;; Tests fail with: asyncssh.misc.ConnectionLost: Connection lost
+ (("(.+)async def test_get_server_host_key_proxy" all indent)
+ (string-append indent "@unittest.skip('disabled by guix')\n"
+ indent "async def test_get_server_host_key_proxy"))
+ (("(.+)async def test_connect_reverse_proxy" all indent)
+ (string-append indent "@unittest.skip('disabled by guix')\n"
+ indent "async def test_connect_reverse_proxy")))))
(replace 'check
(lambda* (#:key tests? inputs outputs #:allow-other-keys)
(when tests?