aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOleg Pykhalov <go.wigust@gmail.com>2020-08-09 10:58:40 +0300
committerOleg Pykhalov <go.wigust@gmail.com>2020-08-09 17:19:22 +0300
commitf18df4f9dea09575b5d40ed6d1461dfface4b7c4 (patch)
tree23ddf9b24d741d1dc08bef6612f25c4b0a58ffe1
parentb554842620a3b09e2b71b2c152fab3c4b0018b41 (diff)
downloadguix-f18df4f9dea09575b5d40ed6d1461dfface4b7c4.tar.gz
guix-f18df4f9dea09575b5d40ed6d1461dfface4b7c4.zip
gnu: Add go-gopkg-in-warnings.
* gnu/packages/golang.scm (go-gopkg-in-warnings): New variable.
-rw-r--r--gnu/packages/golang.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index e5d646e6a4..b991008bb9 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -5090,3 +5090,25 @@ structures and algorithms in Go.")
(arguments
`(#:import-path "github.com/emirpasic/gods/utils"
#:unpack-path "github.com/emirpasic/gods"))))
+
+(define-public go-gopkg-in-warnings
+ (package
+ (name "go-gopkg-in-warnings")
+ (version "0.1.2")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/go-warnings/warnings")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1kzj50jn708cingn7a13c2wdlzs6qv89dr2h4zj8d09647vlnd81"))))
+ (build-system go-build-system)
+ (arguments
+ `(#:import-path "gopkg.in/warnings.v0"))
+ (home-page "https://gopkg.in/warnings.v0")
+ (synopsis "Error handling with non-fatal errors")
+ (description "Package warnings implements error handling with non-fatal
+errors (warnings).")
+ (license license:bsd-2)))
-avail'>...Ricardo Wurmus 2016-01-29Rename 'dmd' to 'shepherd' in comments and strings....Alex Kost 2015-06-18install: Turn off deduplication for the binary tarball....Ludovic Courtès 2015-06-10install: Really overwrite TARGET/var/guix/profiles/system-1-link....Ludovic Courtès 2015-04-29install: Make /var/lock....Ludovic Courtès 2015-04-14install: Add a procedure to build a self-contained binary tarball....Ludovic Courtès 2015-03-31install: Create /var/tmp....Ludovic Courtès 2014-12-09system: Don't make /boot/grub/grub.cfg a symlink to the store....Ludovic Courtès 2014-12-04system: Make /boot/grub/grub.cfg an indirect GC root....Ludovic Courtès 2014-09-12activation: Make the /bin/sh symlink at activation time....Ludovic Courtès 2014-09-10install: Gracefully handle corner cases with 'guix system init foo /'....Ludovic Courtès 2014-09-03Move operating system helpers from (guix build …) to (gnu build …)....Ludovic Courtès