aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJanneke Nieuwenhuizen <janneke@gnu.org>2024-11-11 15:09:03 +0100
committerJanneke Nieuwenhuizen <janneke@gnu.org>2024-12-03 08:33:13 +0100
commitef15b483792ed9fee6943b85dd86ff97a09d6705 (patch)
tree892b51021a91ce488de5378b9f1f6608df6bb332
parentfbf815dc84b96ac60567b01490b19b073c9348db (diff)
downloadguix-ef15b483792ed9fee6943b85dd86ff97a09d6705.tar.gz
guix-ef15b483792ed9fee6943b85dd86ff97a09d6705.zip
gnu: texinfo-4: Fix [cross-]build with gcc-14 and the 64bit Hurd.
* gnu/packages/texinfo.scm (texinfo-4): When building for the 64bit Hurd, or cross-compiling, add "-Wno-incompatible-pointer-types" to #:configure-flags. Change-Id: Ia0503e3f5c7aa5354a949b69035a1be6f93ec85f
-rw-r--r--gnu/packages/texinfo.scm50
1 files changed, 27 insertions, 23 deletions
diff --git a/gnu/packages/texinfo.scm b/gnu/packages/texinfo.scm
index 98429cb059..13c780897e 100644
--- a/gnu/packages/texinfo.scm
+++ b/gnu/packages/texinfo.scm
@@ -7,7 +7,7 @@
;;; Copyright © 2019 Pierre-Moana Levesque <pierre.moana.levesque@gmail.com>
;;; Copyright © 2019, 2020 Mathieu Othacehe <m.othacehe@gmail.com>
;;; Copyright © 2020 Nicolas Goaziou <mail@nicolasgoaziou.fr>
-;;; Copyright © 2020, 2023 Janneke Nieuwenhuizen <janneke@gnu.org>
+;;; Copyright © 2020, 2023, 2024 Janneke Nieuwenhuizen <janneke@gnu.org>
;;; Copyright © 2021 Maxime Devos <maximedevos@telenet.be>
;;; Copyright © 2022 ( <paren@disroot.org>
;;;
@@ -169,31 +169,35 @@ is on expressing the content semantically, avoiding physical markup commands.")
(modify-inputs (package-native-inputs texinfo)
(prepend automake)))
(arguments
- (substitute-keyword-arguments (package-arguments texinfo)
- ((#:phases phases)
- `(modify-phases ,phases
- (add-after 'unpack 'fix-configure
- (lambda* (#:key inputs native-inputs #:allow-other-keys)
- ;; Replace outdated config.sub and config.guess.
- (with-directory-excursion "build-aux"
- (for-each
- (lambda (file)
- (install-file (string-append
- (assoc-ref
- (or native-inputs inputs) "automake")
- "/share/automake-"
- ,(version-major+minor
- (package-version automake))
- "/" file) "."))
- '("config.sub" "config.guess")))
- #t))
- ;; Build native version of tools before running 'build phase.
- ,@(if (%current-target-system)
- `((add-before 'build 'make-native-gnu-lib
+ (append
+ (substitute-keyword-arguments (package-arguments texinfo)
+ ((#:phases phases)
+ `(modify-phases ,phases
+ (add-after 'unpack 'fix-configure
+ (lambda* (#:key inputs native-inputs #:allow-other-keys)
+ ;; Replace outdated config.sub and config.guess.
+ (with-directory-excursion "build-aux"
+ (for-each
+ (lambda (file)
+ (install-file (string-append
+ (assoc-ref
+ (or native-inputs inputs) "automake")
+ "/share/automake-"
+ ,(version-major+minor
+ (package-version automake))
+ "/" file) "."))
+ '("config.sub" "config.guess")))
+ #t))
+ ;; Build native version of tools before running 'build phase.
+ ,@(if (%current-target-system)
+ `((add-before 'build 'make-native-gnu-lib
(lambda* (#:key inputs #:allow-other-keys)
(invoke "make" "-C" "tools/gnulib/lib")
#t)))
- '())))))))
+ '()))))
+ (if (or (target-hurd64?) (%current-target-system))
+ (list #:configure-flags ''("CFLAGS=-Wno-incompatible-pointer-types"))
+ '())))))
(define-public info-reader
;; The idea of this package is to have the standalone Info reader without