aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Ford <fanquake@gmail.com>2023-08-22 11:59:29 +0100
committerEfraim Flashner <efraim@flashner.co.il>2023-09-08 14:31:58 +0300
commite65ae376715676c39c70cad58a3c7803192cfcc6 (patch)
tree16ef3eec05e6e057cdd5a68657936f2c4b5652b9
parent3228dcd7dbb532293d451d4d411df59f462e0287 (diff)
downloadguix-e65ae376715676c39c70cad58a3c7803192cfcc6.tar.gz
guix-e65ae376715676c39c70cad58a3c7803192cfcc6.zip
gnu: libupnp: Update to 1.14.18.
* gnu/packages/upnp.scm (libupnp): Update to 1.14.18. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
-rw-r--r--gnu/packages/upnp.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/upnp.scm b/gnu/packages/upnp.scm
index bc93f51563..1602136e29 100644
--- a/gnu/packages/upnp.scm
+++ b/gnu/packages/upnp.scm
@@ -96,14 +96,14 @@ over IRC, instant messaging, network games, and most server software.")
(define-public libupnp
(package
(name "libupnp")
- (version "1.14.17")
+ (version "1.14.18")
(source
(origin
(method url-fetch)
(uri (string-append "https://github.com/pupnp/pupnp/releases/download"
"/release-" version "/libupnp-" version".tar.bz2"))
(sha256
- (base32 "1yvgrfdhvsz6br3i7k37pigcw25rnzkxdx4sjizqqhm0xd1751wv"))))
+ (base32 "1sywi1l0sc9s55hryfwqb5y5fhyyqx6ida5i7bk8m1p27klwx9qn"))))
(native-inputs
(list pkg-config))
(build-system gnu-build-system)
6e981f37b7304b1803dbafc75acc0b8f6'>gnu/local.mk
@@ -1511,6 +1511,7 @@ dist_patch_DATA = \
%D%/packages/patches/icecat-use-system-wide-dir.patch \
%D%/packages/patches/icedtea-7-hotspot-aarch64-use-c++98.patch \
%D%/packages/patches/icedtea-7-hotspot-pointer-comparison.patch \
+ %D%/packages/patches/icu4c-icu-22132-fix-vtimezone.patch \
%D%/packages/patches/icu4c-fix-TestHebrewCalendarInTemporalLeapYear.patch \
%D%/packages/patches/id3lib-CVE-2007-4460.patch \
%D%/packages/patches/id3lib-UTF16-writing-bug.patch \
diff --git a/gnu/packages/icu4c.scm b/gnu/packages/icu4c.scm
index 2031d72768..6f09fae65c 100644
--- a/gnu/packages/icu4c.scm
+++ b/gnu/packages/icu4c.scm
@@ -126,8 +126,9 @@ C/C++ part.")
(base32
"0iccpdvc0kvpww5a31k9gjkqigyz016i7v80r9zamd34w4fl6mx4"))
(patches
- (cons
- (search-patch
+ (append
+ (search-patches
+ "icu4c-icu-22132-fix-vtimezone.patch"
"icu4c-fix-TestHebrewCalendarInTemporalLeapYear.patch")
(origin-patches (package-source icu4c))))))))
diff --git a/gnu/packages/patches/icu4c-icu-22132-fix-vtimezone.patch b/gnu/packages/patches/icu4c-icu-22132-fix-vtimezone.patch
new file mode 100644
index 0000000000..4fe520318a
--- /dev/null
+++ b/gnu/packages/patches/icu4c-icu-22132-fix-vtimezone.patch
@@ -0,0 +1,31 @@
+Source: https://unicode-org.atlassian.net/browse/ICU-22132?focusedCommentId=166752
+Author: Sean Burke
+License:
+Fixes: https://bugzilla.mozilla.org/show_bug.cgi?id=1843007
+
+diff --git a/icu4c/source/i18n/vtzone.cpp b/icu4c/source/i18n/vtzone.cpp
+index 3035106701..5e738e11fa 100644
+--- a/source/i18n/vtzone.cpp
++++ b/source/i18n/vtzone.cpp
+@@ -1735,14 +1735,14 @@ VTimeZone::write(VTZWriter& writer, UErrorCode& status) const {
+ }
+ }
+ } else {
+- UnicodeString icutzprop;
+- UVector customProps(nullptr, uhash_compareUnicodeString, status);
++ UVector customProps(uprv_deleteUObject, uhash_compareUnicodeString, status);
+ if (olsonzid.length() > 0 && icutzver.length() > 0) {
+- icutzprop.append(olsonzid);
+- icutzprop.append(u'[');
+- icutzprop.append(icutzver);
+- icutzprop.append(u']');
+- customProps.addElement(&icutzprop, status);
++ LocalPointer<UnicodeString> icutzprop(new UnicodeString(ICU_TZINFO_PROP), status);
++ icutzprop->append(olsonzid);
++ icutzprop->append(u'[');
++ icutzprop->append(icutzver);
++ icutzprop->append(u']');
++ customProps.adoptElement(icutzprop.orphan(), status);
+ }
+ writeZone(writer, *tz, &customProps, status);
+ }