aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArtyom V. Poptsov <poptsov.artyom@gmail.com>2024-09-02 12:57:12 +0300
committerArtyom V. Poptsov <poptsov.artyom@gmail.com>2024-10-13 12:57:03 +0300
commite4f5eb6c01727ef143e533019e74830e00d6f5d2 (patch)
treee39357f4042eba901475b66c57608ee685039898
parent36c794c0ed058ee414cbb90c577f6ade5170470a (diff)
downloadguix-e4f5eb6c01727ef143e533019e74830e00d6f5d2.tar.gz
guix-e4f5eb6c01727ef143e533019e74830e00d6f5d2.zip
gnu: Add bin-graph.
* gnu/packages/linux.scm (bin-graph): New variable. Change-Id: I7405cbc00e038d024d035fb100473352c9a7b59d Reviewed-by: Zheng Junjie <zhengjunjie@iscas.ac.cn> Reviewed-by: Andreas Enge <andreas@enge.fr>
-rw-r--r--gnu/packages/linux.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 5888ea470e..91ad014a81 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -1842,6 +1842,40 @@ emulate optical devices such as DVD and CD-ROM drives.")
graphics card on Optimus laptops.")
(license license:gpl2))))
+(define-public bin-graph
+ ;; XXX: The upstream does not have tags yet.
+ (let ((commit "1dd42e3e8e123e993d6c287967502c8d4b36f9ba")
+ (revision "0"))
+ (package
+ (name "bin-graph")
+ (version (git-version "0.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/8dcc/bin-graph")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1wjkl789r7iys3nnyk813gsdxwwy2ryxgxirx5xw02lzk790dywl"))))
+ (arguments
+ (list #:tests? #f ; no tests
+ #:make-flags
+ #~(list (string-append "CC=" #$(cc-for-target))
+ (string-append "PREFIX=" #$output)
+ (string-append "INSTALL_DIR=" #$output "/bin"))
+ #:phases
+ #~(modify-phases %standard-phases
+ (delete 'configure)))) ; no configure script
+ (build-system gnu-build-system)
+ (inputs (list libpng))
+ (home-page "https://github.com/8dcc/bin-graph")
+ (synopsis "Visualize binary files")
+ (description
+ "@code{bin-graph} provides a simple way of visualizing the different regions
+of a binary file.")
+ (license license:gpl3))))
+
(define-public ddcci-driver-linux
(package
(name "ddcci-driver-linux")