aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAdam Faiz <adam.faiz@disroot.org>2025-02-15 09:50:02 +0800
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2025-02-24 20:55:25 +0100
commite2bdba585a902a7408f048a74110aa91fc4fcbe1 (patch)
treecdd4a6e97ee897837065796074dac27f4cc7c3a4
parentb7154c276c7ab8ed1613433db29c648549301566 (diff)
downloadguix-e2bdba585a902a7408f048a74110aa91fc4fcbe1.tar.gz
guix-e2bdba585a902a7408f048a74110aa91fc4fcbe1.zip
gnu: Add tuxemon.
* gnu/packages/games.scm (tuxemon): New variable. Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com>
-rw-r--r--gnu/packages/games.scm62
1 files changed, 62 insertions, 0 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 30aaf0767a..36ca9d4b27 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -87,6 +87,7 @@
;;; Copyright © 2024 Jan Wielkiewicz <tona_kosmicznego_smiecia@interia.pl>
;;; Copyright © 2024 Ashvith Shetty <ashvithshetty10@gmail.com>
;;; Copyright © 2025 Sharlatan Hellseher <sharlatanus@gmail.com>
+;;; Copyright © 2023-2025 Adam Faiz <adam.faiz@disroot.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -6217,6 +6218,67 @@ safety of the Chromium vessel.")
;; by the Expat License.
(license (list license:clarified-artistic license:expat))))
+(define-public tuxemon
+ (let ((commit "19708725f8b2d939e39b726f49a8a078eba8bf32")
+ (revision "0"))
+ (package
+ (name "tuxemon")
+ (version (git-version "0.4.34" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/Tuxemon/Tuxemon")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0jdhk6xs4895gifxlkaxk7625wvw2yl1yc6ciay137dk78amhp86"))
+ (modules '((guix build utils)))
+ (snippet
+ #~(begin
+ (substitute* "requirements.txt"
+ (("pygame-ce") "pygame") ; The pygame-ce fork isn't packaged in Guix
+ (("pygame-menu-ce") "pygame-menu")
+ (("==") ">="))
+ (substitute* "tuxemon/constants/paths.py"
+ (("LIBDIR, ....,") "LIBDIR,"))))))
+ (build-system python-build-system)
+ (native-inputs (list python-flit-core python-setuptools))
+ (propagated-inputs
+ (list python-babel
+ python-cbor
+ python-neteria
+ python-natsort
+ python-pygame
+ python-pyscroll
+ python-pytmx
+ python-pillow
+ python-prompt-toolkit
+ python-pydantic-2
+ python-pygame-menu
+ python-pyyaml
+ python-requests))
+ (arguments
+ (list #:tests? #f ; Tests won't be updated until the API stabilises
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'install 'install-mods
+ (lambda _
+ (let ((site (string-append #$output "/lib/python"
+ #$(version-major+minor
+ (package-version python))
+ "/site-packages/tuxemon/mods")))
+ (mkdir-p site)
+ (copy-recursively "mods" site)))))))
+ (home-page "https://www.tuxemon.org/")
+ (synopsis "Monster-fighting RPG")
+ (description
+ "Tuxemon is a monster-fighting RPG.
+In the spirit of other clones like SuperTux and SuperTuxKart,
+Tuxemon aims to create a game with its own unique style
+that sets it apart from other monster fighting RPGs.")
+ (license license:gpl3+))))
+
(define-public tuxpaint
(package
(name "tuxpaint")