aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFelix Lechner <felix.lechner@lease-up.com>2024-06-17 09:15:48 -0700
committerAndreas Enge <andreas@enge.fr>2024-07-09 21:09:45 +0200
commite13f7d48e5b989f5dbd27c19ac81989ec6b3ec6e (patch)
treedaa81c5bd1c24e5ee8150b04fe8da3c104078f12
parent045ada83591665f56161cfa7166926bf620d5002 (diff)
downloadguix-e13f7d48e5b989f5dbd27c19ac81989ec6b3ec6e.tar.gz
guix-e13f7d48e5b989f5dbd27c19ac81989ec6b3ec6e.zip
gnu: opensmtpd: Correct hard coded path.
* gnu/packages/mail.scm (opensmtpd)[arguments]: Substitute non existent path. Change-Id: I6da8c3650be66f7e2297ea6174a66b7f0b1bc0c0 Signed-off-by: Andreas Enge <andreas@enge.fr>
-rw-r--r--gnu/packages/mail.scm4
1 files changed, 4 insertions, 0 deletions
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index 1bf4debe68..b7b06c1d99 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -3316,6 +3316,10 @@ from the Cyrus IMAP project.")
;; Fix some incorrectly hard-coded external tool file names.
(add-after 'unpack 'patch-FHS-file-names
(lambda _
+ ;; avoids warning smtpd: couldn't enqueue offline message
+ ;; smtpctl exited abnormally
+ (substitute* "usr.sbin/smtpd/smtpd.h"
+ (("/usr/bin/smtpctl") "/run/setuid-programs/smtpctl"))
(substitute* "usr.sbin/smtpd/smtpctl.c"
;; ‘gzcat’ is auto-detected at compile time, but ‘cat’ isn't.
(("/bin/cat") (which "cat")))