aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-09-16 11:04:40 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-11-09 21:33:51 +0000
commite05d3eabd240fa29b32529284c328f5b027a57f2 (patch)
tree1ca662689b881f8a4f1643b7f71ca52a7ffbc617
parentb34aac7490bbe7eaf73dee67e4585f0163a6ba64 (diff)
downloadguix-e05d3eabd240fa29b32529284c328f5b027a57f2.tar.gz
guix-e05d3eabd240fa29b32529284c328f5b027a57f2.zip
gnu: go-github-com-nbrownus-go-metrics-prometheus: Fix build.
Fix the build as senn in <https://ci.guix.gnu.org/build/5804385/log/raw>. * gnu/packages/prometheus.scm (go-github-com-nbrownus-go-metrics-prometheus): Fix build. [arguments]: <#:phases>: Add 'fix-embed-files. Change-Id: I0164c81caf203d93cdc8d1745b5a15bf77be9fb5
-rw-r--r--gnu/packages/prometheus.scm22
1 files changed, 21 insertions, 1 deletions
diff --git a/gnu/packages/prometheus.scm b/gnu/packages/prometheus.scm
index 533a922d0b..fe2fa18e95 100644
--- a/gnu/packages/prometheus.scm
+++ b/gnu/packages/prometheus.scm
@@ -112,7 +112,27 @@ x/net/trace)} tracing wrappers @code{net.Conn}, both inbound
;; The project looks abandoned, tests failed with a new go-metrics, see
;; <https://github.com/nbrownus/go-metrics-prometheus/pull/2>.
#:tests? #f
- #:import-path "github.com/nbrownus/go-metrics-prometheus"))
+ #:import-path "github.com/nbrownus/go-metrics-prometheus"
+ #:phases
+ #~(modify-phases %standard-phases
+ ;; TODO: Implement it in go-build-system.
+ ;;
+ ;; This happens due to Golang can't determine the valid directory of
+ ;; the module of embed file which is symlinked during setup
+ ;; environment phase, but easy resolved after coping file from the
+ ;; store to the build directory of the current package, see details
+ ;; in Golang source:
+ ;;
+ ;; - URL: <https://github.com/golang/go/blob/>
+ ;; - commit: 82c14346d89ec0eeca114f9ca0e88516b2cda454
+ ;; - file: src/cmd/go/internal/load/pkg.go#L2059
+ (add-after 'unpack 'fix-embed-files
+ (lambda _
+ (for-each (lambda (file)
+ (let ((file-store-path (readlink file)))
+ (delete-file file)
+ (copy-recursively file-store-path file)))
+ (find-files "src" ".*(editions_defaults.binpb)$")))))))
(native-inputs
(list go-github-com-stretchr-testify))
(propagated-inputs