diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-01-18 23:20:45 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2020-03-17 03:00:46 +0100
commitdf10a64efc9fd9cd725dfc67347fdbfa1e1075c2 (patch)
tree7d716cd20096f314587fc841ea1e51a2efb7139e
parent97845067b12764ea8d4d7f207213144f7ccb8881 (diff)
downloadguix-df10a64efc9fd9cd725dfc67347fdbfa1e1075c2.tar.gz
guix-df10a64efc9fd9cd725dfc67347fdbfa1e1075c2.zip
gnu: shogun: Use HTTPS home page.
* gnu/packages/machine-learning.scm (shogun)[home-page]: Use HTTPS.
-rw-r--r--gnu/packages/machine-learning.scm2
1 files changed, 1 insertions, 1 deletions
diff --git a/gnu/packages/machine-learning.scm b/gnu/packages/machine-learning.scm
index 62ef7b84e4..7deb6ee29a 100644
--- a/gnu/packages/machine-learning.scm
+++ b/gnu/packages/machine-learning.scm
@@ -566,7 +566,7 @@ optimizing, and searching weighted finite-state transducers (FSTs).")
;; Non-portable SSE instructions are used so building fails on platforms
;; other than x86_64.
(supported-systems '("x86_64-linux"))
- (home-page "http://shogun-toolbox.org/")
+ (home-page "https://shogun-toolbox.org/")
(synopsis "Machine learning toolbox")
(description
"The Shogun Machine learning toolbox provides a wide range of unified and
bin")) (for-each (cut install-file <> (string-append #$output:utils "/bin/")) '("stcompdirs" "stcrashreceiver" "stdisco" "stdiscosrv" "stevents" "stfileinfo" "stfinddevice" "stfindignored" "stgenfiles" "strelaypoolsrv" "strelaysrv" "stsigtool" "stvanity" "stwatchfile" "ursrv"))))) (add-after 'install 'install-docs (lambda _ (let ((man (string-append #$output "/share/man")) (man:utils (string-append #$output:utils "/share/man"))) ;; Install all the man pages to "out". (for-each (lambda (file) (install-file file (string-append man "/man" (string-take-right file 1)))) (find-files "src/github.com/syncthing/syncthing/man" "\\.[1-9]")) ;; Copy all the man pages to "utils" (copy-recursively man man:utils) ;; Delete extraneous man pages from "out" and "utils", ;; respectively. (delete-file (string-append man "/man1/stdiscosrv.1")) (delete-file (string-append man "/man1/strelaysrv.1")) (delete-file (string-append man:utils "/man1/syncthing.1")))))))) (synopsis "Decentralized continuous file system synchronization") (description "Syncthing is a peer-to-peer file synchronization tool that supports a wide variety of computing platforms. It uses the Block Exchange Protocol.") (home-page "https://github.com/syncthing/syncthing") (properties '((release-monitoring-url . "https://syncthing.net/downloads/") (upstream-name . "syncthing-source") ;; The hashing code greatly benefits from newer architecture support. (tunable? . #t))) (license mpl2.0))) (define-public syncthing-gtk ;; The commit used below corresponds to the latest commit of the ;; python3-port branch maintained by Debian. Upstream hasn't bothered ;; porting to Python 3 (see: ;; https://github.com/kozec/syncthing-gtk/issues/487). (let ((revision "1") (commit "c46fbd8ad1d12d409da8942702a2f119cf45514a")) (package (name "syncthing-gtk") (version (git-version "0.9.4.4" revision commit)) (source (origin (method git-fetch) (uri (git-reference (url "https://salsa.debian.org/debian/syncthing-gtk.git") (commit commit))) (file-name (git-file-name name version)) (sha256 (base32 "1x1c8snf0jpgjmyyidjw0015ksk5ishqn817wx8vs9i0lfgnnbbg")))) (build-system python-build-system) (arguments `(#:phases (modify-phases %standard-phases (add-after 'unpack 'hardcode-dependencies (lambda* (#:key inputs #:allow-other-keys) (let ((psmisc (assoc-ref inputs "psmisc")) (syncthing (assoc-ref inputs "syncthing"))) ;; Hardcode dependencies paths to avoid propagation. (substitute* "syncthing_gtk/tools.py" (("killall") (string-append psmisc "/bin/killall"))) (substitute* "syncthing_gtk/configuration.py" (("/usr/bin/syncthing") (string-append syncthing "/bin/syncthing")))))) (add-after 'unpack 'fix-autostart-path ;; Change the autostart .desktop file 'Exec' command so it finds ;; the Python wrapper of 'syncthing-gtk', rather than the unwrapped ;; '.syncthing-gtk-real'. (lambda _ (substitute* "syncthing_gtk/tools.py" (("return executable") "return \"syncthing-gtk\"")))) (add-after 'unpack 'remove-windows.py (lambda _ ;; A Windows-specific module that fails to load with ;; "ModuleNotFoundError: No module named 'msvcrt'. (delete-file "syncthing_gtk/windows.py"))) (add-after 'wrap 'wrap-libs (lambda* (#:key outputs #:allow-other-keys) (let ((out (assoc-ref outputs "out"))) (wrap-program (string-append out "/bin/syncthing-gtk") `("GI_TYPELIB_PATH" ":" prefix (,(getenv "GI_TYPELIB_PATH")))))))))) (inputs (list bash-minimal gtk+ libappindicator libnotify python-bcrypt python-dateutil python-pycairo python-pygobject psmisc syncthing)) (home-page "https://github.com/syncthing/syncthing-gtk") (synopsis "GTK3 based GUI and notification area icon for Syncthing") (description "@code{syncthing-gtk} is a GTK3 Python based GUI and notification area icon for Syncthing. Supported Syncthing features: @itemize @item Everything that WebUI can display @item Adding, editing and deleting nodes @item Adding, editing and deleting repositories @item Restart, shutdown server @item Editing daemon settings @end itemize\n") (license gpl2)))) (define-public qsyncthingtray (deprecated-package "qsyncthingtray" syncthing-gtk)) (define-public go-github-com-syncthing-notify (let ((commit "69c7a957d3e261f9744f46b3dd4d608d8480ad90") (revision "5")) (package (name "go-github-com-syncthing-notify") (version (git-version "0.0.0" revision commit)) (source (origin (method git-fetch) (uri (git-reference (url "https://github.com/syncthing/notify") (commit commit))) (file-name (git-file-name name version)) (sha256 (base32 "1mmdzyfnmjabyhbipl4bggw4w5nlxyyjp0d93qd824kj07kmsr1f")))) (build-system go-build-system) (arguments '(#:import-path "github.com/syncthing/notify")) (propagated-inputs (list go-golang-org-x-sys)) (synopsis "File system event notification library") (description "This package provides @code{notify}, a file system event notification library in Go.") (home-page "https://github.com/syncthing/notify") (license expat))))