aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Rohleder <mike@rohleder.de>2020-07-20 21:00:16 +0200
committerEfraim Flashner <efraim@flashner.co.il>2020-07-21 10:03:57 +0300
commitdc4adbf6852164d1222495e760ac15df4dc0dc16 (patch)
tree4153f6f7bef2c5ebe9b23d20e62e955af2afba8c
parent84d31a5c356bdff541cfaec70630330d69408e14 (diff)
downloadguix-dc4adbf6852164d1222495e760ac15df4dc0dc16.tar.gz
guix-dc4adbf6852164d1222495e760ac15df4dc0dc16.zip
gnu: font-jetbrains-mono: Update to 2.001.
* gnu/packages/fonts.scm (font-jetbrains-mono): Update to 2.001. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
-rw-r--r--gnu/packages/fonts.scm13
1 files changed, 11 insertions, 2 deletions
diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
index 38b342f770..763e8028e2 100644
--- a/gnu/packages/fonts.scm
+++ b/gnu/packages/fonts.scm
@@ -1741,7 +1741,7 @@ This package provides the TrueType fonts.")
(define-public font-jetbrains-mono
(package
(name "font-jetbrains-mono")
- (version "1.0.3")
+ (version "2.001")
(source
(origin
(method url-fetch)
@@ -1749,8 +1749,17 @@ This package provides the TrueType fonts.")
(string-append "https://download.jetbrains.com/fonts/"
"JetBrainsMono-" version ".zip"))
(sha256
- (base32 "0zvhwmpdwpm4vywmm6i9a4najz0c7vfi411yikgkd66l5hwd1p6f"))))
+ (base32 "0r3dk3kn536rik4mvpcjin9mwmifl3v8mawvb4a5l59pww0vcxzq"))))
(build-system font-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'install-license-files
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (doc (string-append out "/share/doc/" ,name "-" ,version)))
+ (install-file "../LICENSE" doc)
+ #t))))))
(home-page "https://www.jetbrains.com/lp/mono/")
(synopsis "Mono typeface for developers")
(description
al Public License for more details. ;;; ;;; You should have received a copy of the GNU General Public License ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>. (define-module (gnu packages openkinect) #:use-module (guix packages) #:use-module (guix git-download) #:use-module (guix build-system cmake) #:use-module ((guix licenses) #:prefix license:) #:use-module (gnu packages pkg-config) #:use-module (gnu packages libusb) #:use-module (gnu packages python) #:use-module (gnu packages python-xyz) #:use-module (gnu packages gl) #:use-module (gnu packages pkg-config) #:use-module (gnu packages image-processing)) (define-public libfreenect (let ((version "0.6.2")) (package (name "libfreenect") (version version) (source (origin (method git-fetch) (uri (git-reference (url "https://github.com/OpenKinect/libfreenect") (commit (string-append "v" version)))) (file-name (git-file-name name version)) (sha256 (base32 "02pb8mcl62kzdcgbnv3rw4nl0f08iw8pjiqqhfy3ycpkvyppw97w")))) (build-system cmake-build-system) (arguments '(#:tests? #f ; package has no tests #:configure-flags '("-DBUILD_FAKENECT=ON" "-DBUILD_CPP=ON" "-DBUILD_EXAMPLES=OFF" ; available in libfreenect-examples "-DBUILD_CV=OFF" ; available in libfreenect-cv "-DBUILD_PYTHON=OFF" ; available in python-libfreenect "-DBUILD_C_SYNC=ON") #:phases (modify-phases %standard-phases (add-after 'install 'install-udev-rules (lambda* (#:key outputs #:allow-other-keys) (let* ((out (assoc-ref outputs "out")) (rules-out (string-append out "/lib/udev/rules.d"))) (install-file "../source/platform/linux/udev/51-kinect.rules" (string-append rules-out "51-kinect.rules")) #t)))))) (native-inputs (list pkg-config)) (inputs (list libusb)) (synopsis "Drivers and libraries for the Xbox Kinect device") (description "libfreenect is a userspace driver for the Microsoft Kinect. It supports: RGB and Depth Images, Motors, Accelerometer, LED and Audio.") (home-page "https://openkinect.org/") (license license:gpl2+)))) ;; Library are already compiled in libfreenect, avoid build it again. (define libfreenect-derived-phases '(modify-phases %standard-phases (add-after 'unpack 'patch-CMakeLists.txt (lambda* (#:key outputs #:allow-other-keys) (substitute* "CMakeLists.txt" ((".*libusb.*") "") (("add_subdirectory \\(src\\)") "") ((".*libfreenectConfig.cmake.*") "")) #t)))) (define-public libfreenect-examples (package (inherit libfreenect) (name "libfreenect-examples") (inputs `(("libfreenect" ,libfreenect) ("glut" ,freeglut))) (arguments `(#:tests? #f ; package has no tests #:configure-flags '("-DBUILD_EXAMPLES=ON" "-DBUILD_FAKENECT=OFF" "-DBUILD_CPP=OFF" "-DBUILD_C_SYNC=OFF" "-DBUILD_CV=OFF") #:phases ,libfreenect-derived-phases)) (synopsis "Examples for libfreenect, the Xbox Kinect device library"))) (define-public libfreenect-opencv (package (inherit libfreenect) (name "libfreenect-opencv") (inputs (list libfreenect opencv)) (arguments `(#:tests? #f ; package has no tests #:configure-flags '("-DBUILD_EXAMPLES=OFF" "-DBUILD_FAKENECT=OFF" "-DBUILD_CPP=OFF" "-DBUILD_C_SYNC=OFF" "-DBUILD_CV=ON") #:phases ,libfreenect-derived-phases)) (synopsis "OpenCV wrapper for libfreenect, the Xbox Kinect device library"))) (define-public python-libfreenect (package (inherit libfreenect) (name "python-libfreenect") (native-inputs (list python-cython)) (inputs (list libfreenect)) (propagated-inputs (list python python-numpy)) (arguments `(#:tests? #f ; package has no tests #:configure-flags '("-DBUILD_EXAMPLES=OFF" "-DBUILD_FAKENECT=OFF" "-DBUILD_CPP=OFF" "-DBUILD_C_SYNC=OFF" "-DBUILD_CV=OFF" "-DBUILD_PYTHON3=ON") #:phases ,libfreenect-derived-phases)) (synopsis "Python wrapper for libfreenect, the Xbox Kinect device library")))