aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-16 17:13:39 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:18:35 +0200
commitcd54081a19f839134ca757301a0e785b672ba633 (patch)
treeb60dd51f5a463b7f6cf2bb5114985b44243b1509
parentbc9bcea942f10dcb8d4dd70ff97fae803159481c (diff)
downloadguix-cd54081a19f839134ca757301a0e785b672ba633.tar.gz
guix-cd54081a19f839134ca757301a0e785b672ba633.zip
gnu: Add texlive-latexdiff.
* gnu/packages/tex.scm (texlive-latexdiff): New variable.
-rw-r--r--gnu/packages/tex.scm37
1 files changed, 37 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 6211544bb6..29da870f97 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -2606,6 +2606,43 @@ Note that embossing will need LibreOffice and @code{odt2braille} as this
project does not deal with embossers drivers.")
(license license:gpl3)))
+(define-public texlive-latexdiff
+ (package
+ (name "texlive-latexdiff")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/man/man1/latexdiff-vc.1"
+ "doc/man/man1/latexdiff-vc.man1.pdf"
+ "doc/man/man1/latexdiff.1"
+ "doc/man/man1/latexdiff.man1.pdf"
+ "doc/man/man1/latexrevise.1"
+ "doc/man/man1/latexrevise.man1.pdf"
+ "doc/support/latexdiff/"
+ "scripts/latexdiff/")
+ (base32
+ "03fnz7gilzwzgsqij10npfy8k2imhk5glfjijr52qgmg28r3xvi1")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (arguments
+ (list #:link-scripts
+ #~(list "latexdiff-vc.pl" "latexdiff.pl" "latexrevise.pl")))
+ (inputs (list perl))
+ (home-page "https://ctan.org/pkg/latexdiff")
+ (synopsis
+ "Determine and mark up significant differences between LaTeX files")
+ (description
+ "Latexdiff is a Perl script for visual mark up and revision of
+significant differences between two LaTeX files. Various options are
+available for visual markup using standard LaTeX packages such as color.
+Changes not directly affecting visible text, for example in formatting
+commands, are still marked in the LaTeX source. A rudimentary revision
+facilility is provided by another Perl script, @command{latexrevise}, which
+accepts or rejects all changes. Manual editing of the difference file can be
+used to override this default behaviour and accept or reject selected changes
+only.")
+ (license license:gpl3)))
+
(define-public texlive-tex-ini-files
(package
(name "texlive-tex-ini-files")
daemon.in: New file. * nix/local.mk (etc/init.d/guix-daemon): New rule. (nodist_sysvinitservice_DATA): Add etc/init.d/guix-daemon.in . (CLEANFILES): Add etc/init.d/guix-daemon . * .gitignore: Add etc/init.d/guix-daemon . Danny Milosavljevic 2020-02-26daemon: Drop 'AT_STATX_DONT_SYNC' flag upon EINVAL....Fixes <https://bugs.gnu.org/39727>. Reported by Paul Garlick <pgarlick@tourbillion-technology.com>. * nix/libstore/gc.cc (LocalStore::removeUnusedLinks) [HAVE_STATX]: Add 'statx_flags' static variables. Clear 'AT_STATX_DONT_SYNC' flag from 'statx_flags' when 'statx' returns EINVAL. Ludovic Courtès 2020-01-12daemon: Fix the displayed GC estimated progress....* nix/libstore/gc.cc (LocalStore::deletePathRecursive): Fix computation of 'fraction'. Take 'bytesInvalidated' into account. Ludovic Courtès 2020-01-12daemon: Account for deleted store files when deduplication is on....Previously, a store item that is a regular file would not be accounted for in the 'bytesFreed' value computed by 'deletePath' because its 'st_nlink' count would always be >= 2. This commit fixes that. * nix/libutil/util.hh (deletePath): Add optional 'linkThreshold' argument. * nix/libutil/util.cc (_deletePath): Add 'linkThreshold' argument and honor it. Pass it down in recursive call. (deletePath): Add 'linkThreshold' and honor it. * nix/libstore/gc.cc (LocalStore::deleteGarbage): Pass 'linkThreshold' argument to 'deletePath', with a value of 2 when PATH is a store item and deduplication is on. Ludovic Courtès